View Issue Details

IDProjectCategoryView StatusLast Update
0003620GNUnettransport servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003620: ./test_transport_api_slow_ats fails
DescriptionAmatus added this testcase to reproduce a peer connectivity issue. Should be investigated.
TagsNo tags attached.

Activities

Christian Grothoff

2015-02-03 01:28

manager   ~0008840

Last edited: 2015-02-03 01:30

View 2 revisions

01:24 <grothoffhome> verification works (as it should, doesn't need ATS), peer1 ATS suggestion _also_ seems to work, then peer 2 makes the ATS suggestion (so ATS service works), but transport drops it on the floor saying "I don't know that neighbour".
01:25 <grothoffhome> So the problem seems to be that transport 2 times out the 'neighbour' entry *before* ATS makes the suggestion (as ATS is delayed), and then is somehow unable to recover from there.01:25 <grothoffhome> So the problem seems to be that transport 2 times out the 'neighbour' entry *before* ATS makes the suggestion (as ATS is delayed), and then is somehow unable to recover from there.
01:28 <grothoffhome> So I suspect one (or more) of the timeouts in gnunet-service-transport_neighbours.c is to blame, as we timeout that entry while the (plugin-level) session is still active.
01:28 <grothoffhome> At that time, the plugin-level session continues to exist, effectively robbing peer1 from the opportunity to reconnect.
01:28 <grothoffhome> (as it is already connected)

Christian Grothoff

2015-02-03 15:39

manager   ~0008841

Ok, changed the logic a bit here to make transport _create_ a neighbor entry when ATS suggests an address (if none exists already).

The timeouts are still an issue, as I think we have connection establishment still a bit backwards, but this should theoretically fix the testcase. Still, we might want to have a more general prohibition on neighbour entries being destroyed while plugin sessions are still active.

Christian Grothoff

2015-02-03 16:41

manager   ~0008842

Key problem that seems to be left: ATS makes address suggestion, but transport service "forgets" it, and ATS doesn't make another one.

Christian Grothoff

2015-02-10 01:04

manager   ~0008850

Test seems to now pass.

Issue History

Date Modified Username Field Change
2015-01-26 23:52 Christian Grothoff New Issue
2015-01-26 23:52 Christian Grothoff Status new => assigned
2015-01-26 23:52 Christian Grothoff Assigned To => Matthias Wachs
2015-02-03 01:28 Christian Grothoff Note Added: 0008840
2015-02-03 01:30 Christian Grothoff Note Edited: 0008840 View Revisions
2015-02-03 15:39 Christian Grothoff Note Added: 0008841
2015-02-03 16:41 Christian Grothoff Note Added: 0008842
2015-02-10 01:03 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2015-02-10 01:04 Christian Grothoff Note Added: 0008850
2015-02-10 01:04 Christian Grothoff Status assigned => resolved
2015-02-10 01:04 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-10 01:04 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed