View Issue Details

IDProjectCategoryView StatusLast Update
0003611gnunet-gtkgnunet-conversation-gtkpublic2018-06-07 00:25
ReporterChristian GrothoffAssigned Toyids 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003611: active call stats active if gnunet-conversation-service is stopped/terminated
DescriptionWhen a call is active and the conversation service is stopped/terminated, the call stays in the 'active' state, even though it is very much dead (and even after the service is resumed, it won't be recovered as the service needs to do a fresh handshake and everything, and thus we cannot automatically reestablish the connection).

What is interesting is that the command-line (gnunet-conversation) tool does update its state properly, so clearly there is just something wrong in how gnunet-conversation-gtk handles some API call.
TagsNo tags attached.

Activities

Christian Grothoff

2015-01-16 12:33

manager   ~0008798

Ok, seems to be less of an issue of -gtk vs cmd-line than caller vs. callee.

Christian Grothoff

2015-01-16 12:48

manager   ~0008799

Fixed in SVN 34903.

Issue History

Date Modified Username Field Change
2015-01-16 12:10 Christian Grothoff New Issue
2015-01-16 12:10 Christian Grothoff Status new => assigned
2015-01-16 12:10 Christian Grothoff Assigned To => yids
2015-01-16 12:33 Christian Grothoff Note Added: 0008798
2015-01-16 12:48 Christian Grothoff Note Added: 0008799
2015-01-16 12:48 Christian Grothoff Status assigned => resolved
2015-01-16 12:48 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-01-16 12:48 Christian Grothoff Resolution open => fixed
2015-01-16 12:48 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed