View Issue Details

IDProjectCategoryView StatusLast Update
0003595GNUnettransport servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003595: valgrind-reported memory leaks in gnunet-transport service (with tcp, udp, http client & server enabled)
Description==9594== 40 bytes in 1 blocks are definitely lost in loss record 41 of 76
==9594== at 0x4C28C20: malloc (vg_replace_malloc.c:296)
==9594== by 0x5A8A943: GNUNET_xmalloc_unchecked_ (common_allocation.c:144)
==9594== by 0x5A8A5EF: GNUNET_xmalloc_ (common_allocation.c:71)
==9594== by 0x40CD6A: clients_handle_send (gnunet-service-transport_clients.c:786)
==9594== by 0x5AC7464: GNUNET_SERVER_inject (server.c:989)
==9594== by 0x5AC80EB: client_message_tokenizer_callback (server.c:1213)
==9594== by 0x5ACA561: GNUNET_SERVER_mst_receive (server_mst.c:221)
==9594== by 0x5AC7759: process_mst (server.c:1063)
==9594== by 0x5AC7D9A: process_incoming (server.c:1154)
==9594== by 0x5A94ED2: receive_ready (connection.c:1095)
==9594== by 0x5AC32E9: run_ready (scheduler.c:595)
==9594== by 0x5AC3B77: GNUNET_SCHEDULER_run (scheduler.c:817)
==9594==
==9594== 63,390 (200 direct, 63,190 indirect) bytes in 1 blocks are definitely lost in loss record 76 of 76
==9594== at 0x4C28C20: malloc (vg_replace_malloc.c:296)
==9594== by 0x5A8A943: GNUNET_xmalloc_unchecked_ (common_allocation.c:144)
==9594== by 0x5A8A5EF: GNUNET_xmalloc_ (common_allocation.c:71)
==9594== by 0x5A91578: GNUNET_CONNECTION_create_from_accept (connection.c:431)
==9594== by 0x5AC5689: process_listen_socket (server.c:415)
==9594== by 0x5AC32E9: run_ready (scheduler.c:595)
==9594== by 0x5AC3B77: GNUNET_SCHEDULER_run (scheduler.c:817)
==9594== by 0x5AD1C61: GNUNET_SERVICE_run (service.c:1502)
==9594== by 0x4080B1: main (gnunet-service-transport.c:1201)
==9594==
TagsNo tags attached.

Activities

Christian Grothoff

2015-02-12 21:13

manager   ~0008876

Fixed the first one in SVN 35248.

Christian Grothoff

2015-02-12 21:15

manager   ~0008877

Closer inspection suggests both were caused by the same issue, and should thus both be considered fixed.

Issue History

Date Modified Username Field Change
2014-12-24 01:08 Christian Grothoff New Issue
2014-12-24 01:08 Christian Grothoff Status new => assigned
2014-12-24 01:08 Christian Grothoff Assigned To => Matthias Wachs
2015-02-11 20:34 Christian Grothoff Assigned To Matthias Wachs =>
2015-02-11 20:34 Christian Grothoff Status assigned => confirmed
2015-02-12 21:13 Christian Grothoff Note Added: 0008876
2015-02-12 21:15 Christian Grothoff Note Added: 0008877
2015-02-12 21:15 Christian Grothoff Status confirmed => resolved
2015-02-12 21:15 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-12 21:15 Christian Grothoff Resolution open => fixed
2015-02-12 21:15 Christian Grothoff Assigned To => Christian Grothoff
2015-02-12 21:15 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed