View Issue Details

IDProjectCategoryView StatusLast Update
0003459GNUnetcadet servicepublic2018-06-07 00:25
ReporterMatthias WachsAssigned ToBart Polot 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003459: Errors after restarting peer
DescriptionIs cadet working correctly with peers restarting?

I have a peer running connected correctly with 4 peers...
After restarting I get :

$ Jun 30 09:04:36-101459 cadet-tun-5625 WARNING malformed PING on V8XX

$ Jun 30 09:04:40-191078 cadet-tun-5625 WARNING malformed PING on 8RW1

Jun 30 09:04:56-576997 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:04:56-577328 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:01-578257 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:01-578577 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:06-579542 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:06-579871 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:11-580031 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:11-580316 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:16-581938 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:16-582240 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:21-585858 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:21-586167 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
Jun 30 09:05:26-591237 cadet-5625 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1218.
TagsNo tags attached.

Relationships

duplicate of 0003405 closedBart Polot Revision 33231: cadet susceptible to dynamic IP-change 

Activities

Bart Polot

2014-06-30 11:15

manager   ~0008486

Last edited: 2014-06-30 11:30

View 2 revisions

Are you sure you are running svn HEAD? I thought I fixed this error in r33829.

Matthias Wachs

2014-07-02 09:54

manager   ~0008496

After updating a peer to rev 33892 and restarting:

Jul 02 09:51:39-834570 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:51:39-834598 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:51:39-834622 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:51:39-834644 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:51:39-834669 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:51:39-834686 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:51:39-834701 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:51:39-834716 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:51:39-834732 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:51:39-834746 cadet-tun-30202 WARNING


Jul 02 09:51:44-839853 cadet-tun-30202 WARNING


Jul 02 09:51:44-839909 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:51:44-839929 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:51:44-839950 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:51:44-839969 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:51:44-839993 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:51:44-840009 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:51:44-840023 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:51:44-840037 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:51:44-840052 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:51:44-840065 cadet-tun-30202 WARNING


Jul 02 09:51:49-841520 cadet-tun-30202 WARNING


Jul 02 09:51:49-841596 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:51:49-841617 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:51:49-841640 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:51:49-841659 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:51:49-841684 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:51:49-841700 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:51:49-841715 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:51:49-841729 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:51:49-841744 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:51:49-841757 cadet-tun-30202 WARNING


Jul 02 09:51:54-843248 cadet-tun-30202 WARNING


Jul 02 09:51:54-843315 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:51:54-843333 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:51:54-843357 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:51:54-843376 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:51:54-843399 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:51:54-843416 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:51:54-843430 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:51:54-843443 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:51:54-843457 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:51:54-843469 cadet-tun-30202 WARNING


Jul 02 09:51:59-848534 cadet-tun-30202 WARNING


Jul 02 09:51:59-848592 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:51:59-848611 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:51:59-848632 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:51:59-848651 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:51:59-848675 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:51:59-848691 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:51:59-848705 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:51:59-848720 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:51:59-848734 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:51:59-848747 cadet-tun-30202 WARNING


Jul 02 09:52:04-851213 cadet-tun-30202 WARNING


Jul 02 09:52:04-851265 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:04-851284 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:04-851306 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:04-851325 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:04-851349 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:04-851365 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:04-851379 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:04-851393 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:04-851408 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:04-851421 cadet-tun-30202 WARNING


Jul 02 09:52:09-855226 cadet-tun-30202 WARNING


Jul 02 09:52:09-855285 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:09-855304 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:09-855326 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:09-855344 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:09-855368 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:09-855384 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:09-855398 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:09-855413 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:09-855427 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:09-855440 cadet-tun-30202 WARNING


Jul 02 09:52:14-859228 cadet-tun-30202 WARNING


Jul 02 09:52:14-859287 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:14-859306 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:14-859326 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:14-859344 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:14-859367 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:14-859383 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:14-859396 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:14-859409 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:14-859423 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:14-859436 cadet-tun-30202 WARNING


Jul 02 09:52:19-862520 cadet-tun-30202 WARNING


Jul 02 09:52:19-862584 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:19-862604 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:19-862626 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:19-862644 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:19-862667 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:19-862683 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:19-862697 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:19-862710 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:19-862724 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:19-862737 cadet-tun-30202 WARNING


Jul 02 09:52:24-863224 cadet-tun-30202 WARNING


Jul 02 09:52:24-863282 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:24-863300 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:24-863321 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:24-863339 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:24-863362 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:24-863378 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:24-863392 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:24-863406 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:24-863421 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:24-863433 cadet-tun-30202 WARNING


Jul 02 09:52:29-868499 cadet-tun-30202 WARNING


Jul 02 09:52:29-868557 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:29-868575 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:29-868595 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:29-868613 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:29-868635 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:29-868650 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:29-868663 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:29-868677 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:29-868690 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:29-868702 cadet-tun-30202 WARNING


Jul 02 09:52:34-871222 cadet-tun-30202 WARNING


Jul 02 09:52:34-871280 cadet-30202 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1219.
Jul 02 09:52:34-871298 cadet-tun-30202 WARNING sending { KX_EPHEMERAL}
Jul 02 09:52:34-871318 cadet-p2p-30202 WARNING PPP DEBUG PEER U8XX
Jul 02 09:52:34-871336 cadet-p2p-30202 WARNING PPP last contact Wed Jul 02 09:51:38 2014
Jul 02 09:52:34-871358 cadet-p2p-30202 WARNING PPP path: 4YCN WX7E 8RWI U8XX
Jul 02 09:52:34-871373 cadet-p2p-30202 WARNING PPP core transmit handle (nil)
Jul 02 09:52:34-871386 cadet-p2p-30202 WARNING PPP DHT GET handle 0x12c4780
Jul 02 09:52:34-871399 cadet-p2p-30202 WARNING PPP # connections over link to peer: 0
Jul 02 09:52:34-871413 cadet-p2p-30202 WARNING PPP DEBUG END
Jul 02 09:52:34-871426 cadet-tun-30202 WARNING

Bart Polot

2014-07-02 12:31

manager   ~0008497

Are there any 'TTT' messages?

Bart Polot

2014-12-16 19:38

manager   ~0008700

Not able to reproduce anymore in new version, tunnel code was heavily changed in the meantime.

Issue History

Date Modified Username Field Change
2014-06-30 09:07 Matthias Wachs New Issue
2014-06-30 09:07 Matthias Wachs Status new => assigned
2014-06-30 09:07 Matthias Wachs Assigned To => Bart Polot
2014-06-30 11:15 Bart Polot Note Added: 0008486
2014-06-30 11:15 Bart Polot Status assigned => feedback
2014-06-30 11:30 Bart Polot Note Edited: 0008486 View Revisions
2014-06-30 16:20 Bart Polot Relationship added duplicate of 0003405
2014-06-30 16:20 Bart Polot Status feedback => resolved
2014-06-30 16:20 Bart Polot Resolution open => fixed
2014-07-02 09:54 Matthias Wachs Note Added: 0008496
2014-07-02 09:54 Matthias Wachs Status resolved => feedback
2014-07-02 09:54 Matthias Wachs Resolution fixed => reopened
2014-07-02 12:31 Bart Polot Note Added: 0008497
2014-11-07 18:53 Christian Grothoff Target Version SVN HEAD => 0.11.0pre66
2014-12-16 19:38 Bart Polot Note Added: 0008700
2014-12-16 19:38 Bart Polot Status feedback => resolved
2014-12-16 19:38 Bart Polot Fixed in Version => 0.11.0pre66
2014-12-16 19:38 Bart Polot Resolution reopened => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed