View Issue Details

IDProjectCategoryView StatusLast Update
0003455GNUnetGNSpublic2018-06-07 00:25
ReporterellAssigned ToMatthias Wachs 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformOSXubuntu-14.04-64amdOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003455: Revision 33824: gnunet-gns-proxy-setup-ca error-message from certutil
Descriptionell@Xubu-14:~/gnunet$ gnunet-gns-proxy-setup-ca
Generating CA
Generating a 2048 bit RSA private key
...............+++
....+++
writing new private key to '/tmp/gnscakeyJDCuCF.pem'
-----
Removing passphrase from key
writing RSA key
Making private key available to gnunet-gns-proxy
Importing CA into browsers
Importing CA info Firefox at /home/ell/.mozilla/firefox/yaqb5vsj.default//
certutil: could not add certificate to token or database: SEC_ERROR_ADDING_CERT: Error adding certificate to database.
Importing CA into Chrome at ~/.pki/nssdb/
Cleaning up.
Steps To Reproducerefer to 0003451
Additional InformationThere is no (ca)-cert with "gnu" or "GNU" in firefox-30.0 when
gnunet-gns-proxy-setup-ca
is started.

(I looked in
Einstellungen->Zertifikate anzeigen->Server
                                   ->Zertifizierungsstellen
                                   ->Andere
                                   ->Personen
                                   ->Ihre Zertifikate)

If gnunet-gns-proxy-setup-ca would provide a ca-file as p12-file, I could
import this p12-File manually into Firefox.
TagsNo tags attached.

Activities

ell

2014-06-25 11:07

reporter   ~0008469

Testing with Firefox-30.0 showed me, there is no need for a proxy.
  http://test.gnu/
works fine and so does
  http://grothoff.org/
without changing preferences.

Matthias Wachs

2014-06-28 08:13

manager   ~0008478

Works fine for me:

CA cert shows immediately in Firefox 30

Authorities -> GNU -> GNU PROXY CA

$ gnunet-gns-proxy-setup-ca
Generating CA
Generating a 2048 bit RSA private key
..+++
......+++
writing new private key to '/tmp/gnscakey3xe89V.pem'
-----
Removing passphrase from key
writing RSA key
Making private key available to gnunet-gns-proxy
Importing CA into browsers
Importing CA info Firefox at /home/xyz/.mozilla/firefox/avrrgb2x.default//
Importing CA into Chrome at ~/.pki/nssdb/
Cleaning up.
===================================
You can now start gnunet-gns-proxy.
Afterwards, configure your browser
 to use a SOCKS proxy on port 7777.
===================================
$

Matthias Wachs

2014-06-28 08:20

manager   ~0008479

This is a xubuntu 14.04 system?



Could you check if /home/ell/.mozilla/firefox/yaqb5vsj.default// is existing and permissions are correct?

ell

2014-06-28 09:53

reporter   ~0008480

System is xubuntu 14.04.

Permissions are ok.

Have you changed something in gnunet-gns-proxy-setup-ca,
because gnunet-gns-proxy-setup-ca now runs without complaining.

If you did not alter gnunet-gns-proxy-setup-ca
then probably I run into a trap.
CA-certs seem to show up in FF after some time delay.
I observed that after deleting GNU PROXY CA-Module
and repeating the loading procedure.
Maybe the issue is due to the starting validity-time of the ca-cert.

Tkx for your help.

Matthias Wachs

2014-06-30 08:56

manager   ~0008481

So for me it showed up "immediately":

So firefox was running, I ran the tool, switched back to FF and check for the cert ... and there it was!

There seem to be no changes, especially since you filed the issue with 33824:
svn info gnunet-gns-proxy-setup-ca
Last Changed Rev: 33747
Last Changed Date: 2014-06-22 21:29:08 +0200 (Sun, 22 Jun 2014)

Issue History

Date Modified Username Field Change
2014-06-24 10:53 ell New Issue
2014-06-24 10:53 ell Status new => assigned
2014-06-24 10:53 ell Assigned To => Matthias Wachs
2014-06-25 11:07 ell Note Added: 0008469
2014-06-28 08:13 Matthias Wachs Note Added: 0008478
2014-06-28 08:20 Matthias Wachs Note Added: 0008479
2014-06-28 08:20 Matthias Wachs Status assigned => feedback
2014-06-28 09:53 ell Note Added: 0008480
2014-06-28 09:53 ell Status feedback => assigned
2014-06-30 08:56 Matthias Wachs Note Added: 0008481
2014-06-30 08:57 Matthias Wachs Status assigned => resolved
2014-06-30 08:57 Matthias Wachs Resolution open => fixed
2014-09-30 10:33 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-09-30 10:33 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed