View Issue Details

IDProjectCategoryView StatusLast Update
0003420gnunet-gtkgnunet-conversation-gtkpublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003420: copy & paste buttons are not implemented
DescriptionThose should allow users to 'easily' add a phone record for another user.
We need to define the exchange format (with nick? without?) and implement the logic itself.
TagsNo tags attached.

Activities

Christian Grothoff

2014-06-04 14:30

manager   ~0008393

I think the answer is to generate a URI for a CNAME record without NICK.
The reason is that
1) caller will (and should) be prompted to enter a label
2) We want to explicitly communicate the current label (and not rely
   on default 'phone', which may be wrong)

So the CNAME value should have the format 'LABEL.PKEY.zkey'. For the URI, we could thus use gnunet://gns/LABEL.PKEY.zkey/.

Christian Grothoff

2014-06-04 14:46

manager   ~0008394

Copy button implemented in SVN 33512.

Christian Grothoff

2014-06-04 15:25

manager   ~0008395

Paste button implemented in SVN 33515.

Issue History

Date Modified Username Field Change
2014-06-02 22:16 Christian Grothoff New Issue
2014-06-02 22:16 Christian Grothoff Status new => assigned
2014-06-02 22:16 Christian Grothoff Assigned To => Christian Grothoff
2014-06-04 14:30 Christian Grothoff Note Added: 0008393
2014-06-04 14:46 Christian Grothoff Note Added: 0008394
2014-06-04 15:25 Christian Grothoff Note Added: 0008395
2014-06-04 15:25 Christian Grothoff Status assigned => resolved
2014-06-04 15:25 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-06-04 15:25 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed