View Issue Details

IDProjectCategoryView StatusLast Update
0003404GNUnettransport servicepublic2018-06-07 00:25
ReporterellAssigned ToMatthias Wachs 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformnat vboxOSXubuntu-14.04-64amdOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003404: misc warnings from cadet and tcp plugin
DescriptionRevision 33229:
...
May 09 19:33:12-283124 cadet-tun-1997 WARNING got 2225857979
May 09 19:33:12-283190 cadet-tun-1997 WARNING towards DSU8
May 09 19:33:13-950702 cadet-tun-1997 WARNING malformed PING on KIQE
May 09 19:33:13-950946 cadet-tun-1997 WARNING e got 3279509203
May 09 19:33:13-951081 cadet-tun-1997 WARNING e towards 0PSP
May 09 19:33:13-951156 cadet-tun-1997 WARNING got 3120115167
May 09 19:33:13-951227 cadet-tun-1997 WARNING towards MNED
May 09 19:33:14-961363 transport-tcp-2007 ERROR Trying to print invalid `tcp' address with size 22
May 09 19:33:14-961817 transport-tcp-2007 ERROR Trying to print invalid `tcp' address with size 10
May 09 19:33:15-179187 transport-tcp-2007 ERROR Trying to print invalid `tcp' address with size 22
May 09 19:33:15-252445 transport-tcp-2007 ERROR Trying to print invalid `tcp' address with size 10
May 09 19:33:16-516443 cadet-tun-1997 WARNING malformed PING on SAJL
May 09 19:33:16-516584 cadet-tun-1997 WARNING e got 1018381961
May 09 19:33:16-518822 cadet-tun-1997 WARNING e towards VDCT
May 09 19:33:16-519055 cadet-tun-1997 WARNING got 4198855849
May 09 19:33:16-519130 cadet-tun-1997 WARNING towards 94IU
May 09 19:33:17-270085 cadet-tun-1997 WARNING malformed PING on KNGC
May 09 19:33:17-270507 cadet-tun-1997 WARNING e got 143654123
May 09 19:33:17-270881 cadet-tun-1997 WARNING e towards 29HT
May 09 19:33:17-271249 cadet-tun-1997 WARNING got 3261272337
...
Steps To Reproducegnunet-arm -c /etc/gnunet.conf -s
TagsNo tags attached.

Activities

ell

2014-05-09 21:24

reporter   ~0008313

Revision 33230:
As long as I observed the error output in this R
I did not see "transport-tcp-2007 ERROR".
Happy feelings will spread out...

ell

2014-05-09 21:28

reporter   ~0008314

Sorry it is again here:

May 09 21:26:20-400906 cadet-tun-12632 WARNING got 2940079705
May 09 21:26:20-400935 cadet-tun-12632 WARNING towards HCRV
May 09 21:26:21-080806 transport-tcp-12635 ERROR Trying to print invalid `tcp' address with size 22
May 09 21:26:25-296044 cadet-tun-12632 WARNING malformed PING on KNGC
May 09 21:26:25-306963 cadet-tun-12632 WARNING e got 489026226
May 09 21:26:25-307078 cadet-tun-12632 WARNING e towards GGNE

Happy feelings are delayed

ell

2014-05-09 21:45

reporter   ~0008315

Last edited: 2014-05-10 19:19

View 3 revisions

But I miss 'tcp' address with size with size 10.
Maybe you got one error.

Add on:
Revision 33231
All is here again:
May 10 19:03:22-431912 cadet-tun-10864 WARNING got 3683569786
May 10 19:03:22-432185 cadet-tun-10864 WARNING towards TNB0
May 10 19:03:22-458979 cadet-10864 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:990.
May 10 19:03:22-460143 cadet-10864 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:990.
May 10 19:03:24-026935 cadet-tun-10864 WARNING malformed PING on SAJL
May 10 19:03:24-026989 cadet-tun-10864 WARNING e got 2658752334
May 10 19:03:24-027010 cadet-tun-10864 WARNING e towards L3F9
May 10 19:03:24-027029 cadet-tun-10864 WARNING got 3979308081
May 10 19:03:24-027047 cadet-tun-10864 WARNING towards ISB4
May 10 19:03:26-168069 nse-10863 WARNING External protocol violation detected at gnunet-service-nse.c:979.
May 10 19:03:26-168476 nse-10863 WARNING External protocol violation detected at gnunet-service-nse.c:1190.
May 10 19:03:27-332208 set-10868 WARNING other peer disconnected prematurely
May 10 19:03:27-332726 set-10868 WARNING other peer disconnected prematurely
May 10 19:03:27-333210 revocation-10866 WARNING Error computing revocation set union with 6DER
May 10 19:03:27-333962 revocation-10866 WARNING Error computing revocation set union with KNGC
May 10 19:03:29-037255 nse-10863 WARNING External protocol violation detected at gnunet-service-nse.c:979.
May 10 19:03:29-039963 nse-10863 WARNING External protocol violation detected at gnunet-service-nse.c:1190.
May 10 19:07:37-008817 ats-10872 ERROR Assertion failed at plugin_ats_proportional.c:673.
May 10 19:07:48-853606 ats-11548 WARNING Trying to set unknown address `DPQI' `udp' `4' to NO
May 10 19:07:48-854014 ats-11548 ERROR Assertion failed at gnunet-service-ats_addresses.c:1190.
May 10 19:07:48-854074 ats-11548 ERROR Assertion failed at gnunet-service-ats_scheduling.c:411.
May 10 19:11:46-074167 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 22
May 10 19:11:46-074529 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 10
May 10 19:11:46-387185 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 22
May 10 19:11:46-392449 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 10

Matthias Wachs

2014-05-12 13:33

manager   ~0008325

My five cents:

Together with NAT, somehow IP adresses with a wrong size enter the system:

Trying to print invalid `tcp' address with size 10
is a wrong size for an IPv4 address of the tcp plugin

22 is an IPv6 address with the wrong size...

I tried to reproduce it on my nat test system but didn't get the error me ...

So:

- What transport plugins are configured?
- How did you configure NAT? (Upnp, traversal method...)

TIA!

ell

2014-05-12 14:50

reporter   ~0008326

/etc/gnunet.conf:

[arm]
SYSTEM_ONLY = YES
USER_ONLY = NO

[PATHS]
DEFAULTCONFIG = /etc/gnunet.conf

[nat]
BEHIND_NAT = YES
PUNCHED_NAT = YES
DISABLEV6 = YES
INTERNAL_ADDRESS = 10.0.2.15
EXTERNAL_ADDRESS = srv1.nerdcamp.net

[hostlist]
OPTIONS = -b -p -e -a
HTTPPORT = 8080
SERVERS = http://v10.gnunet.org/hostlist
EXTERNAL_DNS_NAME = srv1.nerdcamp.net

[datastore-mysql]
CONFIG = /home/ell/~/.my.cnf


~/.config/gnunet.conf:

[arm]
SYSTEM_ONLY = NO
USER_ONLY = YES
DEFAULTSERVICES = gns

[uri]
fs = gnunet-fs-gtk

[transport]
PLUGINS = tcp udp

[transport-tcp]
PORT = 2086
ADVERTISED_PORT = 2086

[transport-udp]
PORT = 2086

[nat]
PUNCHED_NAT = YES
DISABLEV6 = YES
INTERNAL_ADDRESS = 10.0.2.15
EXTERNAL_ADDRESS = srv1.nerdcamp.net

[hostlist]
OPTIONS = -b -e -p -a
HTTPPORT = 8080
SERVERS = http://v10.gnunet.org/hostlist
EXTERNAL_DNS_NAME = srv1.nerdcamp.net


[gnunet-namestore-gtk]
NICK_EXPIRATION = 1 week

[gnunet-fs-gtk]
MAX_PARALLEL_DOWNLOADS = 128
MAX_PARALLEL_REQUESTS = 100000
DEFAULT_DOWNLOAD_DIRECTORY = ~/Downloads
MAKE_UPDATEABLE_PUBLICATIONS_BY_DEFAULT = YES
MAKE_NAMESPACE_PUBLICATIONS_BY_DEFAULT = NO
MAKE_GLOBAL_PUBLICATIONS_BY_DEFAULT = YES
MAIN_WINDOW_X = 0
MAIN_WINDOW_Y = 25
MAIN_WINDOW_WIDTH = 1855
MAIN_WINDOW_HEIGHT = 1105
MAIN_WINDOW_MAXIMIZED = YES

Maybe the problem ist connected to bugtracker 0003401.

ell

2014-05-14 15:31

reporter   ~0008341

Could there be some kind of Ip4/IP6 address mixing in gnunet?
Candidates for address mixing are:
10.0.2.2 often seen in gnunet-gtk, my default route to nat
10.0.2.15 my internal eth0
Xubu-14 my virtual machine name
dip0.t-ipconnect.de (I configured: srv1.nerdcamp.net)
I don't see the settings of my gnunet.conf in gnunet-gtk.

Bart Polot

2014-05-15 20:32

manager   ~0008347

FYI: The CADET errors should be fixed now, please (re)open a separate report if you still see them!

ell

2014-05-16 08:26

reporter   ~0008349

Not seen up to now:
May 10 19:11:46-074167 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 22
May 10 19:11:46-074529 transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 10

Matthias Wachs

2014-05-19 14:28

manager   ~0008356

GNUNET_TRANSPORT_address_to_string is called from

gnunet-peerinfo
gnunet-transport
gnunet-ats

extending api to find the source of the invalid address

Matthias Wachs

2014-05-19 16:42

manager   ~0008357

Error messages like
"Failure: Cannot convert address to string for peer `<PEER>'
would be useful...

ell

2014-05-20 08:34

reporter   ~0008358

Last edited: 2014-05-20 12:10

View 2 revisions

Will test today.

OK, here my observations for R-33332:

1.) No "transport-tcp-10867 ERROR Trying to print invalid `tcp' address with size 22/10" seen.

2.) Around the changing of the dynamic IP I got
...
May 20 11:32:48-771083 cadet-tun-6063 WARNING malformed PING on SAJL
May 20 11:33:53-856287 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:33:53-857050 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:33:58-862325 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:33:58-863139 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:34:03-865940 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:34:03-866398 cadet-6063 ERROR Assertion failed at gnunet-service-cadet_tunnel.c:1136.
May 20 11:34:08-803074 cadet-tun-6063 WARNING malformed PING on SAJL
...
But only this messages, no looping messages seen.


3.) gnunet-gtk produces lots of
...
Mai 20 12:01:45-851919 gnunet-peerinfo-gtk-6083 ERROR Assertion failed at gnunet-peerinfo-gtk.c:835.
Mai 20 12:01:45-852002 gnunet-peerinfo-gtk-6083 ERROR Assertion failed at gnunet-peerinfo-gtk.c:835.
Mai 20 12:01:45-852073 gnunet-peerinfo-gtk-6083 ERROR Assertion failed at gnunet-peerinfo-gtk.c:835.
...
This message seems to loop.

4.) Can't deliver
"Failure: Cannot convert address to string for peer", it's not seen so far.

Matthias Wachs

2014-05-20 18:06

manager   ~0008361

1 && 4) OK ... then we wait for the message to show up again

3) is related to 0003406

ell

2014-05-26 17:35

reporter   ~0008364

Last edited: 2014-05-26 18:23

View 3 revisions

It's here again after long time not seen:
 
Revision 33395

gnunet@Xubu-14:~$ gnunet-arm -c /etc/gnunet.conf -s
gnunet@Xubu-14:~$ May 26 17:29:20-824823 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:25-839454 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:26-853845 transport-tcp-15018 ERROR Trying to print invalid `tcp' address with size 10
May 26 17:29:26-866490 transport-tcp-15018 ERROR Trying to print invalid `tcp' address with size 10
May 26 17:29:26-873692 transport-tcp-15018 ERROR Trying to print invalid `tcp' address with size 10
May 26 17:29:26-940360 transport-tcp-15018 ERROR Trying to print invalid `tcp' address with size 10
May 26 17:29:30-829269 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:35-829700 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:40-838906 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:45-845693 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:50-840147 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:29:55-850241 cadet-tun-15015 WARNING malformed PING on SAJL
May 26 17:30:00-856432 cadet-tun-15015 WARNING malformed PING on SAJL

and in Revision: 33397

May 26 18:16:53-346662 cadet-tun-11756 WARNING malformed PING on JUAF
May 26 18:16:53-752869 transport-11759 ERROR Trying to transmit ACK to peer `201.22.132.71:2086' but not session found!
May 26 18:16:58-195068 cadet-tun-11756 WARNING malformed PING on JUAF
May 26 18:16:59-655982 transport-tcp-11759 ERROR Trying to print invalid `tcp' address with size 10
May 26 18:16:59-749517 transport-tcp-11759 ERROR Trying to print invalid `tcp' address with size 10
May 26 18:16:59-750412 transport-tcp-11759 ERROR Trying to print invalid `tcp' address with size 10
May 26 18:16:59-750887 transport-tcp-11759 ERROR Trying to print invalid `tcp' address with size 10
May 26 18:17:38-435108 cadet-tun-11756 WARNING malformed PING on JUAFision 33397:

Matthias Wachs

2014-05-27 14:19

manager   ~0008368

Error was moved from tcp plugin to clients to find the source:
So if a clients prints an error message similar to
"Failure: Cannot convert address to string for peer ABCD"

an new(!) bug should be filed containing the error message.
The original error was removed from the plugin, all clients including:

gnunet-ats/transport/peerinfo/peerinfo-gtk

support address to string conversion error handling

Christian Grothoff

2014-06-01 10:40

manager   ~0008372

So can we call this resolved?

Matthias Wachs

2014-06-02 09:34

manager   ~0008376

The " ERROR Trying to print invalid `tcp' address with size 10" is fixed as the handling is moved to the respective client using this function.

Since this bug consists of multiple error messages I would prefer to close it and open a separate new bug for each issue still appearing.

If someone disagrees just reopen the bug...

Issue History

Date Modified Username Field Change
2014-05-09 19:40 ell New Issue
2014-05-09 19:40 ell Status new => assigned
2014-05-09 19:40 ell Assigned To => Matthias Wachs
2014-05-09 21:24 ell Note Added: 0008313
2014-05-09 21:28 ell Note Added: 0008314
2014-05-09 21:45 ell Note Added: 0008315
2014-05-10 15:07 ell Note Edited: 0008315 View Revisions
2014-05-10 19:19 ell Note Edited: 0008315 View Revisions
2014-05-10 23:30 Christian Grothoff Summary Really sorry about this. => misc warnings from cadet and tcp plugin
2014-05-12 13:33 Matthias Wachs Note Added: 0008325
2014-05-12 13:33 Matthias Wachs Status assigned => feedback
2014-05-12 14:50 ell Note Added: 0008326
2014-05-12 14:50 ell Status feedback => assigned
2014-05-14 15:31 ell Note Added: 0008341
2014-05-15 20:32 Bart Polot Note Added: 0008347
2014-05-16 08:26 ell Note Added: 0008349
2014-05-19 14:28 Matthias Wachs Note Added: 0008356
2014-05-19 16:42 Matthias Wachs Note Added: 0008357
2014-05-19 16:42 Matthias Wachs Status assigned => feedback
2014-05-20 08:34 ell Note Added: 0008358
2014-05-20 08:34 ell Status feedback => assigned
2014-05-20 12:10 ell Note Edited: 0008358 View Revisions
2014-05-20 18:06 Matthias Wachs Note Added: 0008361
2014-05-26 17:35 ell Note Added: 0008364
2014-05-26 18:21 ell Note Edited: 0008364 View Revisions
2014-05-26 18:23 ell Note Edited: 0008364 View Revisions
2014-05-27 14:19 Matthias Wachs Note Added: 0008368
2014-06-01 10:40 Christian Grothoff Note Added: 0008372
2014-06-02 09:34 Matthias Wachs Note Added: 0008376
2014-06-02 09:34 Matthias Wachs Status assigned => resolved
2014-06-02 09:34 Matthias Wachs Resolution open => fixed
2014-09-30 10:34 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-09-30 10:34 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed