View Issue Details

IDProjectCategoryView StatusLast Update
0003386GNUnethostlist daemonpublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003386: hostlist http server does not listen on IPv6
DescriptionThis was observed on FreeBSD, should be checked on other systems and fixed.
TagsNo tags attached.

Activities

Matthias Wachs

2014-04-24 09:26

manager   ~0008269

Does not occur on my system:

$ ./gnunet-daemon-hostlist -p
Apr 24 09:23:50-487061 hostlist-4355 DEBUG Advertising not enabled on this hostlist server
Apr 24 09:23:50-487490 hostlist-4355 INFO Hostlist service starts on fulcrum.net.in.tum.de:8080
Apr 24 09:23:50-487516 hostlist-4355 INFO Address to obtain hostlist: `http://fulcrum.net.in.tum.de:8080/'


$ wget -6 http://fulcrum.net.in.tum.de:8080/
--2014-04-24 09:25:48-- http://fulcrum.net.in.tum.de:8080/
Resolving fulcrum.net.in.tum.de (fulcrum.net.in.tum.de)... 2001:4ca0:2001:11:226:b9ff:fe7d:84ed
Connecting to fulcrum.net.in.tum.de (fulcrum.net.in.tum.de)|2001:4ca0:2001:11:226:b9ff:fe7d:84ed|:8080... connected.

$ wget -4 http://fulcrum.net.in.tum.de:8080/
--2014-04-24 09:25:40-- http://fulcrum.net.in.tum.de:8080/
Resolving fulcrum.net.in.tum.de (fulcrum.net.in.tum.de)... 127.0.1.1
Connecting to fulcrum.net.in.tum.de (fulcrum.net.in.tum.de)|127.0.1.1|:8080... connected.

Matthias Wachs

2014-04-24 11:18

manager   ~0008270

Cannot reproduce on freebsd 9.1

[root@freebsd91 ~]# sockstat -4 -l | grep 8080
root gnunet-dae 73582 8 tcp4 *:8080 *:*
[root@freebsd91 ~]# sockstat -6 -l | grep 8080
root gnunet-dae 73582 7 tcp6 *:8080 *:*

Christian Grothoff

2014-06-03 10:43

manager   ~0008386

Looked at the code, the reason was that we used a BINDTO option on the system in question, and that one did only take a v4 or a v6 IP address (but not both, and not a hostname). I've now updated the code to allow specifying a BINDTOIPV4 and a BINDTOIPV6 option, so once configured correctly the service should now be able to bind to IPv4 and IPv6 while also restricting which IPs are being bound.

Issue History

Date Modified Username Field Change
2014-04-23 19:26 Christian Grothoff New Issue
2014-04-23 19:26 Christian Grothoff Status new => assigned
2014-04-23 19:26 Christian Grothoff Assigned To => Matthias Wachs
2014-04-23 19:28 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2014-04-23 19:28 Christian Grothoff Priority normal => urgent
2014-04-24 09:26 Matthias Wachs Note Added: 0008269
2014-04-24 11:18 Matthias Wachs Note Added: 0008270
2014-04-24 11:18 Matthias Wachs Status assigned => feedback
2014-04-24 11:18 Matthias Wachs Resolution open => unable to reproduce
2014-06-03 10:43 Christian Grothoff Note Added: 0008386
2014-06-03 10:43 Christian Grothoff Status feedback => assigned
2014-06-03 10:44 Christian Grothoff Status assigned => resolved
2014-06-03 10:44 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-06-03 10:44 Christian Grothoff Resolution unable to reproduce => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed