View Issue Details

IDProjectCategoryView StatusLast Update
0003384GNUnetconsensus servicepublic2018-06-07 00:25
ReporterBart PolotAssigned ToFlorian Dold 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003384: Consensus crash while running secretsharing profiler
Descriptioncore.25223.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
core.25235.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus

Program terminated with signal SIGABRT, Aborted.
#0 0x00007f0bf1880389 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007f0bf1880389 in raise () from /usr/lib/libc.so.6
#1 0x00007f0bf1881788 in abort () from /usr/lib/libc.so.6
#2 0x00007f0bf2f35020 in GNUNET_abort () at common_logging.c:289
#3 0x00007f0bf2f6cb4b in GNUNET_SCHEDULER_cancel (task=1004493731513019834) at scheduler.c:950
#4 0x00007f0bf2f71b0d in GNUNET_SERVER_client_disconnect (client=0x1f1e560) at server.c:1476
#5 0x0000000000401ad2 in destroy_session (session=0x1f1de50) at gnunet-service-consensus.c:347
#6 0x0000000000405bfa in shutdown_task (cls=0x0, tc=0x7fff9fe40d00) at gnunet-service-consensus.c:1324
#7 0x00007f0bf2f6bd47 in run_ready (rs=0x1f1c890, ws=0x1f1c920) at scheduler.c:595
#8 0x00007f0bf2f6c5d5 in GNUNET_SCHEDULER_run (task=0x7f0bf2f7887a <service_task>, task_cls=0x7fff9fe410a0)
    at scheduler.c:817
#9 0x00007f0bf2f7a60e in GNUNET_SERVICE_run (argc=3, argv=0x7fff9fe41338, service_name=0x406725 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405dc1 <run>, task_cls=0x0) at service.c:1493
#10 0x0000000000405ff8 in main (argc=3, argv=0x7fff9fe41338) at gnunet-service-consensus.c:1402
Additional Information#0 0x00007f0bf1880389 in raise () from /usr/lib/libc.so.6
No symbol table info available.
#1 0x00007f0bf1881788 in abort () from /usr/lib/libc.so.6
No symbol table info available.
#2 0x00007f0bf2f35020 in GNUNET_abort () at common_logging.c:289
No locals.
#3 0x00007f0bf2f6cb4b in GNUNET_SCHEDULER_cancel (task=1004493731513019834) at scheduler.c:950
        t = 0x0
        prev = 0x1f1df20
        p = GNUNET_SCHEDULER_PRIORITY_COUNT
        to = 1
        ret = 0x18
        __FUNCTION__ = "GNUNET_SCHEDULER_cancel"
#4 0x00007f0bf2f71b0d in GNUNET_SERVER_client_disconnect (client=0x1f1e560) at server.c:1476
        server = 0xdf0adba0df0adba
        n = 0x2e401f27f70
        __FUNCTION__ = "GNUNET_SERVER_client_disconnect"
#5 0x0000000000401ad2 in destroy_session (session=0x1f1de50) at gnunet-service-consensus.c:347
        i = 0
        __FUNCTION__ = "destroy_session"
#6 0x0000000000405bfa in shutdown_task (cls=0x0, tc=0x7fff9fe40d00) at gnunet-service-consensus.c:1324
        __FUNCTION__ = "shutdown_task"
#7 0x00007f0bf2f6bd47 in run_ready (rs=0x1f1c890, ws=0x1f1c920) at scheduler.c:595
        p = GNUNET_SCHEDULER_PRIORITY_SHUTDOWN
        pos = 0x1f1dd80
        tc = {reason = GNUNET_SCHEDULER_REASON_SHUTDOWN, read_ready = 0x1f1c890, write_ready = 0x1f1c920}
        __FUNCTION__ = "run_ready"
#8 0x00007f0bf2f6c5d5 in GNUNET_SCHEDULER_run (task=0x7f0bf2f7887a <service_task>, task_cls=0x7fff9fe410a0)
    at scheduler.c:817
        rs = 0x1f1c890
        ws = 0x1f1c920
        timeout = {rel_value_us = 0}
        ret = 2
        shc_int = 0x1f1d2e0
        shc_term = 0x1f1d3a0
        shc_quit = 0x1f1d520
        shc_hup = 0x1f1d5e0
        shc_pipe = 0x1f1d460
        last_tr = 263
        busy_wait_warning = 1
        pr = 0x1f1c810
        c = 0 '\000'
        __FUNCTION__ = "GNUNET_SCHEDULER_run"
#9 0x00007f0bf2f7a60e in GNUNET_SERVICE_run (argc=3, argv=0x7fff9fe41338, service_name=0x406725 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405dc1 <run>, task_cls=0x0) at service.c:1493
        err = 0
        ret = 3
        cfg_fn = 0x1f14700 "~/.config/gnunet.conf"
        opt_cfg_fn = 0x1f14850 "/tmp/testbedOZ6n6m/4/config"
        loglev = 0x0
        logfile = 0x0
        do_daemonize = 0
        i = 4218305
        skew_offset = 139689302127752
        skew_variance = 140735875912320
        clock_offset = 4200000
        sctx = {cfg = 0x1f14720, server = 0x1f1d960, addrs = 0x0, service_name = 0x406725 "consensus",
          task = 0x405dc1 <run>, task_cls = 0x0, v4_denied = 0x0, v6_denied = 0x0, v4_allowed = 0x1f29d90,
          v6_allowed = 0x1f1c830, my_handlers = 0x1f215b0, addrlens = 0x0, lsocks = 0x1f17600, shutdown_task = 4,
          timeout = {rel_value_us = 18446744073709551615}, ret = 1, ready_confirm_fd = -1, require_found = 1,
          match_uid = 1, match_gid = 1, options = GNUNET_SERVICE_OPTION_NONE}
        cfg = 0x1f14720
        xdg = 0x0
---Type <return> to continue, or q <return> to quit---
        service_options = {{shortName = 99 'c', name = 0x7f0bf2f881ad "config",
            argumentHelp = 0x7f0bf2f881b4 "FILENAME",
            description = 0x7f0bf2f881c0 "use configuration file FILENAME", require_argument = 1,
            processor = 0x7f0bf2f59b47 <GNUNET_GETOPT_set_string>, scls = 0x7fff9fe41158}, {shortName = 100 'd',
            name = 0x7f0bf2f881e0 "daemonize", argumentHelp = 0x0,
            description = 0x7f0bf2f881f0 "do daemonize (detach from terminal)", require_argument = 0,
            processor = 0x7f0bf2f59b1a <GNUNET_GETOPT_set_one>, scls = 0x7fff9fe41144}, {shortName = 104 'h',
            name = 0x7f0bf2f88214 "help", argumentHelp = 0x0, description = 0x7f0bf2f88219 "print this help",
            require_argument = 0, processor = 0x7f0bf2f595e1 <GNUNET_GETOPT_format_help_>, scls = 0x0}, {
            shortName = 76 'L', name = 0x7f0bf2f88229 "log", argumentHelp = 0x7f0bf2f8822d "LOGLEVEL",
            description = 0x7f0bf2f88238 "configure logging to use LOGLEVEL", require_argument = 1,
            processor = 0x7f0bf2f59b47 <GNUNET_GETOPT_set_string>, scls = 0x7fff9fe41150}, {shortName = 108 'l',
            name = 0x7f0bf2f8825a "logfile", argumentHelp = 0x7f0bf2f88262 "LOGFILE",
            description = 0x7f0bf2f88270 "configure logging to write logs to LOGFILE", require_argument = 1,
            processor = 0x7f0bf2f59b47 <GNUNET_GETOPT_set_string>, scls = 0x7fff9fe41148}, {shortName = 118 'v',
            name = 0x7f0bf2f8829b "version", argumentHelp = 0x0,
            description = 0x7f0bf2f882a3 "print the version number", require_argument = 0,
            processor = 0x7f0bf2f5959b <GNUNET_GETOPT_print_version_>, scls = 0x7f0bf2f882bc}, {
            shortName = 0 '\000', name = 0x0, argumentHelp = 0x0, description = 0x0, require_argument = 0,
            processor = 0x0, scls = 0x0}}
        __FUNCTION__ = "GNUNET_SERVICE_run"
#10 0x0000000000405ff8 in main (argc=3, argv=0x7fff9fe41338) at gnunet-service-consensus.c:1402
        ret = 0
        __FUNCTION__ = "main"
(gdb)
TagsNo tags attached.

Activities

Florian Dold

2014-04-15 01:54

developer   ~0008247

I'm not able to reproduce this. With which parameters / configuration did you start the secretsharing profiler?

The stack trace is kind of strange ... why does server.c cancel a task twice (the assertion at scheduler.c:950)? I'm not sure what exactly is going wrong there.

Bart Polot

2014-04-15 02:04

manager   ~0008248

I was running the standard secretsharing as always, trying to reproduce the previous crashes after your fix.

Christian Grothoff

2014-06-04 15:34

manager   ~0008396

Can you still reproduce it?

Bart Polot

2014-06-17 14:37

manager   ~0008438

Still very much reproductible:

[bart@voyager ~/g/src/secretsharing] (master % u=)$ ./gnunet-secretsharing-profiler -c test_secretsharing.conf -n16 -d |& tee log | grep -v DEBUG
[bart@voyager ~/g/src/secretsharing] (master % u=)$ ls -l core*
-rw------- 1 bart users 651264 Jun 17 14:32 core.17331.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17339.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17347.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17351.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17355.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17360.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17364.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17368.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17373.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17380.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17384.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17389.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
-rw------- 1 bart users 651264 Jun 17 14:32 core.17396.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus
[bart@voyager ~/g/src/secretsharing] (master % u=)$ debug
Multiple files, using core.17331.!tmp!gnunet!lib!gnunet!libexec!gnunet-service-consensus

Program terminated with signal SIGABRT, Aborted.
#0 0x00007f019a829d67 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007f019a829d67 in raise () from /usr/lib/libc.so.6
#1 0x00007f019a82b118 in abort () from /usr/lib/libc.so.6
#2 0x00007f019beea71f in GNUNET_abort () at common_logging.c:289
#3 0x00007f019bf1214a in GNUNET_MQ_discard (mqm=0x1e058d0) at mq.c:262
#4 0x00007f019bf13c96 in GNUNET_MQ_destroy (mq=0x1dde8f0) at mq.c:789
#5 0x0000000000401ab2 in destroy_session (session=0x1ddeef0) at gnunet-service-consensus.c:342
#6 0x0000000000405c72 in shutdown_task (cls=0x0, tc=0x7fff61cd4790) at gnunet-service-consensus.c:1324
#7 0x00007f019bf21e31 in run_ready (rs=0x1ddcb10, ws=0x1ddcba0) at scheduler.c:595
#8 0x00007f019bf226d0 in GNUNET_SCHEDULER_run (task=0x7f019bf2e999 <service_task>, task_cls=0x7fff61cd4b10)
    at scheduler.c:817
#9 0x00007f019bf30742 in GNUNET_SERVICE_run (argc=3, argv=0x7fff61cd4da8, service_name=0x4067a5 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405e39 <run>, task_cls=0x0) at service.c:1498
#10 0x0000000000406070 in main (argc=3, argv=0x7fff61cd4da8) at gnunet-service-consensus.c:1402

Bart Polot

2014-06-17 14:38

manager   ~0008439

[bart@voyager ~/g/src/secretsharing] (master % u=)$ git svn info
Path: .
URL: https://gnunet.org/svn/gnunet/src/secretsharing
Repository Root: https://gnunet.org/svn
Repository UUID: 140774ce-b5e7-0310-ab8b-a85725594a96
Revision: 33704
Node Kind: directory
Schedule: normal
Last Changed Author: grothoff
Last Changed Rev: 33593
Last Changed Date: 2014-06-08 00:09:28 +0200 (Sun, 08 Jun 2014)

Bart Polot

2014-06-17 14:41

manager   ~0008440

[New LWP 17339]

warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Core was generated by `/tmp/gnunet/lib//gnunet/libexec/gnunet-service-consensus -c /tmp/testbedY4jw1V/'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007f528bf74d67 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007f528bf74d67 in raise () from /usr/lib/libc.so.6
#1 0x00007f528bf76118 in abort () from /usr/lib/libc.so.6
#2 0x00007f528d63571f in GNUNET_abort () at common_logging.c:289
#3 0x00007f528d65d14a in GNUNET_MQ_discard (mqm=0xd458d0) at mq.c:262
#4 0x00007f528d65ec96 in GNUNET_MQ_destroy (mq=0xd1e8b0) at mq.c:789
#5 0x0000000000401ab2 in destroy_session (session=0xd1f080) at gnunet-service-consensus.c:342
#6 0x0000000000405c72 in shutdown_task (cls=0x0, tc=0x7fff24d03410) at gnunet-service-consensus.c:1324
#7 0x00007f528d66ce31 in run_ready (rs=0xd1cad0, ws=0xd1cb60) at scheduler.c:595
#8 0x00007f528d66d6d0 in GNUNET_SCHEDULER_run (task=0x7f528d679999 <service_task>, task_cls=0x7fff24d03790)
    at scheduler.c:817
#9 0x00007f528d67b742 in GNUNET_SERVICE_run (argc=3, argv=0x7fff24d03a28, service_name=0x4067a5 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405e39 <run>, task_cls=0x0) at service.c:1498
#10 0x0000000000406070 in main (argc=3, argv=0x7fff24d03a28) at gnunet-service-consensus.c:1402


[New LWP 17360]

warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Core was generated by `/tmp/gnunet/lib//gnunet/libexec/gnunet-service-consensus -c /tmp/testbedY4jw1V/'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007fbd91226d67 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007fbd91226d67 in raise () from /usr/lib/libc.so.6
#1 0x00007fbd91228118 in abort () from /usr/lib/libc.so.6
#2 0x00007fbd928e771f in GNUNET_abort () at common_logging.c:289
#3 0x00007fbd9290f14a in GNUNET_MQ_discard (mqm=0xc968d0) at mq.c:262
#4 0x00007fbd92910c96 in GNUNET_MQ_destroy (mq=0xc6f8b0) at mq.c:789
#5 0x0000000000401ab2 in destroy_session (session=0xc6fed0) at gnunet-service-consensus.c:342
#6 0x0000000000405c72 in shutdown_task (cls=0x0, tc=0x7ffff4af0410) at gnunet-service-consensus.c:1324
#7 0x00007fbd9291ee31 in run_ready (rs=0xc6dad0, ws=0xc6db60) at scheduler.c:595
#8 0x00007fbd9291f6d0 in GNUNET_SCHEDULER_run (task=0x7fbd9292b999 <service_task>, task_cls=0x7ffff4af0790)
    at scheduler.c:817
#9 0x00007fbd9292d742 in GNUNET_SERVICE_run (argc=3, argv=0x7ffff4af0a28, service_name=0x4067a5 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405e39 <run>, task_cls=0x0) at service.c:1498
#10 0x0000000000406070 in main (argc=3, argv=0x7ffff4af0a28) at gnunet-service-consensus.c:1402


[New LWP 17396]

warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Core was generated by `/tmp/gnunet/lib//gnunet/libexec/gnunet-service-consensus -c /tmp/testbedY4jw1V/'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007f2b250fbd67 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007f2b250fbd67 in raise () from /usr/lib/libc.so.6
#1 0x00007f2b250fd118 in abort () from /usr/lib/libc.so.6
#2 0x00007f2b267bc71f in GNUNET_abort () at common_logging.c:289
#3 0x00007f2b267e414a in GNUNET_MQ_discard (mqm=0x22a58d0) at mq.c:262
#4 0x00007f2b267e5c96 in GNUNET_MQ_destroy (mq=0x227e8f0) at mq.c:789
#5 0x0000000000401ab2 in destroy_session (session=0x227f0c0) at gnunet-service-consensus.c:342
#6 0x0000000000405c72 in shutdown_task (cls=0x0, tc=0x7fff21bb4450) at gnunet-service-consensus.c:1324
#7 0x00007f2b267f3e31 in run_ready (rs=0x227cb10, ws=0x227cba0) at scheduler.c:595
#8 0x00007f2b267f46d0 in GNUNET_SCHEDULER_run (task=0x7f2b26800999 <service_task>, task_cls=0x7fff21bb47d0)
    at scheduler.c:817
#9 0x00007f2b26802742 in GNUNET_SERVICE_run (argc=3, argv=0x7fff21bb4a68, service_name=0x4067a5 "consensus",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405e39 <run>, task_cls=0x0) at service.c:1498
#10 0x0000000000406070 in main (argc=3, argv=0x7fff21bb4a68) at gnunet-service-consensus.c:1402

Bart Polot

2014-06-17 14:43

manager   ~0008441

I still have the log and the coredumps around, if needed.

Florian Dold

2014-06-26 19:42

developer   ~0008476

Should be fixed in r33873 (was a problem with MQ).

Issue History

Date Modified Username Field Change
2014-04-15 00:37 Bart Polot New Issue
2014-04-15 00:37 Bart Polot Status new => assigned
2014-04-15 00:37 Bart Polot Assigned To => Florian Dold
2014-04-15 01:54 Florian Dold Note Added: 0008247
2014-04-15 02:04 Bart Polot Note Added: 0008248
2014-06-04 15:33 Christian Grothoff Assigned To Florian Dold => Bart Polot
2014-06-04 15:33 Christian Grothoff Status assigned => feedback
2014-06-04 15:34 Christian Grothoff Note Added: 0008396
2014-06-17 14:37 Bart Polot Note Added: 0008438
2014-06-17 14:37 Bart Polot Status feedback => assigned
2014-06-17 14:37 Bart Polot Assigned To Bart Polot => Florian Dold
2014-06-17 14:38 Bart Polot Note Added: 0008439
2014-06-17 14:41 Bart Polot Note Added: 0008440
2014-06-17 14:43 Bart Polot Note Added: 0008441
2014-06-26 19:42 Florian Dold Note Added: 0008476
2014-06-26 19:42 Florian Dold Status assigned => feedback
2014-12-12 20:27 Christian Grothoff Status feedback => resolved
2014-12-12 20:27 Christian Grothoff Resolution open => fixed
2014-12-12 20:27 Christian Grothoff Fixed in Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed