View Issue Details

IDProjectCategoryView StatusLast Update
0003340GNUnetcore servicepublic2018-06-07 00:25
ReporterMatthias WachsAssigned ToChristian Grothoff 
PriorityurgentSeverityblockReproducibilitysometimes
Status closedResolutionunable to reproduce 
Product Version0.10.0 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003340: CORE connections not established in both directions
DescriptionI have to peers:
fulcrum.net.in.tum.de: R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG
gnunet.org: DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0


One peer shows core connected the second not:

gnunet9@sam:~/svn/gnunet$ gnunet-core
...
Peer `R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG'
...
gnunet9@sam:~/svn/gnunet$


mwachs@fulcrum:~$ gnunet-core
Peer `BQJ3MNIK9S5DN5PMJPU14F10CVGV8DM76RMN6J72DJSITE804UGG'
Peer `SG6CQU4TAFA0EJIC6PICCGEOUKGFV9L73CE1AE8JTA7EOA7S65OG'
mwachs@fulcrum:~$


Peers are connected in transport level and can exchange data:

mwachs@fulcrum:~$ gnunet-transport -i -a
Peer `DPQI': udp udp.0.gnunet.informatik.tu-muenchen.de:2086 in state `S_CONNECTED' until Fri Mar 21 10:26:47 2014

Transmission from R8TT to DPQI:

mwachs@fulcrum:~$ gnunet-transport -p DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0 -s
^CDisconnected from peer `DPQI' while benchmarking
Transmitted 19126 bytes/s (77824 bytes in 4068 ms)

gnunet9@sam:~/svn/gnunet$ gnunet-transport -p R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG -b
^CReceived 15443 bytes/s (77824 bytes in 5 s)


Transmission from DPQI to R8TT:

gnunet9@sam:~/svn/gnunet$ gnunet-transport -p R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG -s
^CDisconnected from peer `R8TT' while benchmarking
Transmitted 21293 bytes/s (217088 bytes in 10 s)

mwachs@fulcrum:~$ gnunet-transport -p DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0 -b
^CReceived 21646 bytes/s (143360 bytes in 6 s)

TagsNo tags attached.

Relationships

related to 0003348 closedChristian Grothoff CORE does not notify clients about connections after restart 
parent of 0003363 closedChristian Grothoff need core KX monitoring API 

Activities

Matthias Wachs

2014-03-21 10:39

manager   ~0008150

After killing core:

mwachs@fulcrum:~$ gnunet-arm -i core
mwachs@fulcrum:~$ gnunet-core
Peer `0AVHT4TD8O60SF9EFF7V3NF6F1SOV4AHMOP853IUIKEPT96TVBI0'
Peer `BQJ3MNIK9S5DN5PMJPU14F10CVGV8DM76RMN6J72DJSITE804UGG'
Peer `SG6CQU4TAFA0EJIC6PICCGEOUKGFV9L73CE1AE8JTA7EOA7S65OG'
Peer `DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0'

Matthias Wachs

2014-03-21 10:57

manager   ~0008151

Both peers run revision 32707

Matthias Wachs

2014-04-07 17:19

manager   ~0008205

Issue occured again, this time both peers lost core connectivity:

fulcrum: RTT
gnunet9: DPQI
Transport connected and exchanging data, core not connected:


wachs@fulcrum:~$ gnunet-transport -i
...
Peer `DPQI': tcp tcp.0.[sam.net.in.tum.de]:2086
...

mwachs@fulcrum:~$ gnunet-peerinfo -s
I am peer `R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG'.


Receving from DPQI:
mwachs@fulcrum:~$ gnunet-transport -p DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0 -b
^CReceived 3175 bytes/s (4096 bytes in 1290 ms)


Sending to DPQI:
mwachs@fulcrum:~$ time gnunet-transport -p DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0 -s
^CDisconnected from peer `DPQI' while benchmarking
Transmitted 8513 bytes/s (45056 bytes in 5 s)

Matthias Wachs

2014-04-07 17:21

manager   ~0008206

gnunet9@sam:~$ gnunet-peerinfo -s
I am peer `DPQIBOOJV8QBS3FGJ6B0K5NTSQ9SULV45H5KCR4HU7PQ64N8Q9F0'.

gnunet9@sam:~$ time gnunet-transport -p R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG -s
^CDisconnected from peer `R8TT' while benchmarking
Transmitted 4458 bytes/s (8192 bytes in 1837 ms)

gnunet9@sam:~$ time gnunet-transport -p R8TTJ9GAL5VIFOFNM8KNT3D83BVQPBNRHJSSD0IME63V821906EG -b
^CReceived 6760 bytes/s (45056 bytes in 6 s)

Christian Grothoff

2014-04-22 15:47

manager   ~0008264

Tried 20x, failed to reproduce.

Issue History

Date Modified Username Field Change
2014-03-21 10:29 Matthias Wachs New Issue
2014-03-21 10:39 Matthias Wachs Note Added: 0008150
2014-03-21 10:57 Matthias Wachs Note Added: 0008151
2014-03-21 14:01 Matthias Wachs Severity major => block
2014-03-21 14:01 Matthias Wachs Description Updated View Revisions
2014-04-04 20:34 Christian Grothoff Priority high => immediate
2014-04-04 20:34 Christian Grothoff Product Version => 0.10.0
2014-04-04 20:34 Christian Grothoff Target Version => 0.10.1
2014-04-07 11:00 Christian Grothoff Priority immediate => urgent
2014-04-07 11:00 Christian Grothoff Status new => acknowledged
2014-04-07 11:00 Christian Grothoff Target Version 0.10.1 => 0.11.0pre66
2014-04-07 11:02 Christian Grothoff Relationship added parent of 0003363
2014-04-07 11:03 Christian Grothoff Relationship added related to 0003348
2014-04-07 17:19 Matthias Wachs Note Added: 0008205
2014-04-07 17:21 Matthias Wachs Note Added: 0008206
2014-04-10 21:53 Christian Grothoff Assigned To => Christian Grothoff
2014-04-10 21:53 Christian Grothoff Status acknowledged => assigned
2014-04-22 15:47 Christian Grothoff Note Added: 0008264
2014-04-22 15:47 Christian Grothoff Status assigned => resolved
2014-04-22 15:47 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-04-22 15:47 Christian Grothoff Resolution open => unable to reproduce
2018-06-07 00:25 Christian Grothoff Status resolved => closed