View Issue Details

IDProjectCategoryView StatusLast Update
0003333GNUnetcadet servicepublic2018-06-07 00:25
ReporterFlorian DoldAssigned ToBart Polot 
PriorityhighSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003333: mesh fails with various errors on consensus profiler
DescriptionNote the various assertions and warnings in the log (Additional Information).
Steps To Reproduce./gnunet-consensus-profiler -n10 -t 10h -c test_consensus.conf -x 100

(using unix as transport plugin)
Additional InformationMar 10 14:21:08-516146 util-32634 INFO Accepting connection from `<unbound UNIX client>': 0x97c5c0
Mar 10 14:21:09-162818 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-201050 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-254318 mesh-chn-32641 WARNING MID 83 not expected (131 - 194), dropping!
Mar 10 14:21:09-254665 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-308265 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-361792 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-416517 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-470403 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-524309 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-578203 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-632216 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-686093 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-740072 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-794015 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-847918 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-901824 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:09-955703 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:10-009566 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:10-063593 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:10-117509 mesh-chn-32664 WARNING MID 31 not expected (95 - 158), dropping!
Mar 10 14:21:11-487036 mesh-32642 ERROR Assertion failed at gnunet-service-mesh_connection.c:2407.
Mar 10 14:21:11-571639 set-32635 WARNING other peer disconnected prematurely
Mar 10 14:21:11-581450 mesh-32653 ERROR Assertion failed at gnunet-service-mesh_connection.c:2746.
Mar 10 14:21:11-628853 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:12-130500 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:13-130943 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:15-133037 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:19-134229 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:27-135285 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:21:43-137350 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
Mar 10 14:22:15-141145 mesh-32709 WARNING Failed checksum validation for a message on tunnel `83M0'
TagsNo tags attached.

Activities

Bart Polot

2014-03-10 14:33

manager   ~0008139

Is this for svn head?

Florian Dold

2014-03-10 14:34

developer   ~0008140

Yes, r32608.

Florian Dold

2014-03-10 14:38

developer   ~0008141

Ok, part of that might have been a missing 'make install' on my part (sorry!), but I'm still getting

Mar 10 14:36:03-883029 mesh-chn-10823 WARNING MID 78 not expected (99 - 162), dropping!
Mar 10 14:36:05-489063 mesh-10793 ERROR Assertion failed at gnunet-service-mesh_peer.c:1599.

Florian Dold

2014-03-10 14:40

developer   ~0008142

Also,
Mar 10 14:39:19-756577 mesh-19815 ERROR Assertion failed at gnunet-service-mesh_connection.c:2746.
still is there.

What set of assertions I get seems really random, any logging output I can provide to you that might help?

Florian Dold

2014-03-10 14:45

developer   ~0008143

I haven (quite random) problems for a small number of peers (n=2), with
Mar 10 14:44:11-833172 mesh-21104 ERROR Assertion failed at gnunet-service-mesh_connection.c:2407.
Mar 10 14:44:11-913464 set-21102 WARNING other peer disconnected prematurely
Mar 10 14:44:12-947607 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'
Mar 10 14:44:13-021698 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'
Mar 10 14:44:13-095901 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'
Mar 10 14:44:13-170363 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'
Mar 10 14:44:13-244570 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'
Mar 10 14:44:13-318893 mesh-21116 WARNING Failed checksum validation for a message on tunnel `6DER'

where the last message just repeats infinitely (?).

Bart Polot

2014-03-10 15:02

manager   ~0008144

The checksum validation failure is most certainly caused by some recent change, I reduced the size of the hashes. Will try to reproduce.

Bart Polot

2014-04-01 02:50

manager   ~0008171

The "unexpected MID" warnings seem to be caused by retransmissions a tad too eager combined with an unfavorable scheduling. It shouldn't affect the result except some wasted traffic.

As for the checksum warning, I wasn't able to reproduce it, it might have been fixed with recent changes. Please report back if seen with r >= 32864.

Bart Polot

2014-05-15 13:20

manager   ~0008342

Recent changes tweaked the key exchange. Anyway, bug not seen in a while.

Issue History

Date Modified Username Field Change
2014-03-10 14:24 Florian Dold New Issue
2014-03-10 14:24 Florian Dold Status new => assigned
2014-03-10 14:24 Florian Dold Assigned To => Bart Polot
2014-03-10 14:26 Florian Dold Priority normal => high
2014-03-10 14:26 Florian Dold Severity minor => crash
2014-03-10 14:33 Bart Polot Note Added: 0008139
2014-03-10 14:34 Florian Dold Note Added: 0008140
2014-03-10 14:38 Florian Dold Note Added: 0008141
2014-03-10 14:40 Florian Dold Note Added: 0008142
2014-03-10 14:45 Florian Dold Note Added: 0008143
2014-03-10 15:02 Bart Polot Note Added: 0008144
2014-03-10 15:02 Bart Polot Status assigned => acknowledged
2014-03-11 23:42 Christian Grothoff Product Version => SVN HEAD
2014-03-11 23:42 Christian Grothoff Target Version => 0.10.1
2014-04-01 02:50 Bart Polot Note Added: 0008171
2014-04-01 02:50 Bart Polot Status acknowledged => feedback
2014-04-07 20:36 Christian Grothoff Target Version 0.10.1 =>
2014-04-11 15:19 Christian Grothoff Target Version => 0.11.0pre66
2014-05-09 18:34 Christian Grothoff Category mesh service => cadet service
2014-05-15 13:20 Bart Polot Note Added: 0008342
2014-05-15 13:20 Bart Polot Status feedback => resolved
2014-05-15 13:20 Bart Polot Fixed in Version => SVN HEAD
2014-05-15 13:20 Bart Polot Resolution open => fixed
2014-05-15 20:25 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed