View Issue Details

IDProjectCategoryView StatusLast Update
0003322GNUnettransport servicepublic2014-04-08 16:41
ReporterChristian GrothoffAssigned ToMatthias Wachs 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003322: transport sends uninitialized memory (valgrind)
Description==26247== Syscall param socketcall.sendto(msg) points to uninitialised byte(s)
==26247== at 0x5EB50CD: send (send.c:27)
==26247== by 0x589BAAF: GNUNET_NETWORK_socket_send (network.c:777)
==26247== by 0x587C736: transmit_ready (connection.c:1324)
==26247== by 0x58A7012: run_ready (scheduler.c:595)
==26247== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26247== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26247== by 0x406018: main (gnunet-service-transport.c:963)
==26247== Address 0x7182bbc is 60 bytes inside a block of size 133 alloc'd
==26247== at 0x4C2B72E: realloc (vg_replace_malloc.c:662)
==26247== by 0x58723B7: GNUNET_xrealloc_ (common_allocation.c:177)
==26247== by 0x587C4A5: transmit_ready (connection.c:1310)
==26247== by 0x58A7012: run_ready (scheduler.c:595)
==26247== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26247== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26247== by 0x406018: main (gnunet-service-transport.c:963)
==26247==
==26289== Syscall param socketcall.sendto(msg) points to uninitialised byte(s)
==26289== at 0x5EB50CD: send (send.c:27)
==26289== by 0x589BAAF: GNUNET_NETWORK_socket_send (network.c:777)
==26289== by 0x587C736: transmit_ready (connection.c:1324)
==26289== by 0x58A7012: run_ready (scheduler.c:595)
==26289== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26289== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26289== by 0x406018: main (gnunet-service-transport.c:963)
==26289== Address 0x718389c is 60 bytes inside a block of size 133 alloc'd
==26289== at 0x4C2B72E: realloc (vg_replace_malloc.c:662)
==26289== by 0x58723B7: GNUNET_xrealloc_ (common_allocation.c:177)
==26289== by 0x587C4A5: transmit_ready (connection.c:1310)
==26289== by 0x58A7012: run_ready (scheduler.c:595)
==26289== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26289== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26289== by 0x406018: main (gnunet-service-transport.c:963)
==26289==
==26278== Syscall param socketcall.sendto(msg) points to uninitialised byte(s)
==26278== at 0x5EB50CD: send (send.c:27)
==26278== by 0x589BAAF: GNUNET_NETWORK_socket_send (network.c:777)
==26278== by 0x587C736: transmit_ready (connection.c:1324)
==26278== by 0x58A7012: run_ready (scheduler.c:595)
==26278== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26278== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26278== by 0x406018: main (gnunet-service-transport.c:963)
==26278== Address 0x7182c3c is 60 bytes inside a block of size 133 alloc'd
==26278== at 0x4C2B72E: realloc (vg_replace_malloc.c:662)
==26278== by 0x58723B7: GNUNET_xrealloc_ (common_allocation.c:177)
==26278== by 0x587C4A5: transmit_ready (connection.c:1310)
==26278== by 0x58A7012: run_ready (scheduler.c:595)
==26278== by 0x58A7824: GNUNET_SCHEDULER_run (scheduler.c:817)
==26278== by 0x58B4252: GNUNET_SERVICE_run (service.c:1508)
==26278== by 0x406018: main (gnunet-service-transport.c:963)
Steps To ReproduceReproduced by adding PREFIX = valgrind to configuration in 0003305.
TagsNo tags attached.

Relationships

child of 0003305 closedFlorian Dold dht-5368 ERROR Assertion failed at transport_api.c:591. 

Activities

Matthias Wachs

2014-02-12 13:02

manager   ~0008098

fixed in revision 32325.
Caused by uninitialized ATS struct

Issue History

Date Modified Username Field Change
2014-02-11 15:04 Christian Grothoff New Issue
2014-02-11 15:04 Christian Grothoff Status new => assigned
2014-02-11 15:04 Christian Grothoff Assigned To => Matthias Wachs
2014-02-11 15:06 Christian Grothoff Relationship added child of 0003305
2014-02-12 13:02 Matthias Wachs Note Added: 0008098
2014-02-12 13:02 Matthias Wachs Status assigned => resolved
2014-02-12 13:02 Matthias Wachs Resolution open => fixed
2014-03-04 22:58 Christian Grothoff Fixed in Version => 0.10.1
2014-04-08 16:41 Christian Grothoff Status resolved => closed