View Issue Details

IDProjectCategoryView StatusLast Update
0003272gnunet-gtkgnunet-fs-gtkpublic2014-04-08 16:42
ReportersnowwieAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Platformx86_64 GNU/LinuxOSDebianOS VersionWheezy
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003272: gnunet-fs-gtk shows no gui anymore, 100% cpu
DescriptionThe gnunet-fs-gtk program appears to be running, utilizing 100% CPU, but it never displays the UI.
note: The program used to work, until I didn't finish indexing 2 files and quit gnunet-gtk.

When selecting to the FileSharing-tab in gnunet-gtk, the area stays black.

Possibly the program is still trying to index files which were not indexed when gnunet-gtk quit the previous time.

I tried:
- kill -2 gnunet-fs-gtk (long wait, nothing happens)
- kill -9 gnunet-fs-gtk
- rebooting the entire Gnunet-pc
- gnunet-unindex the 2 files
- moving "/var/lib/gnunet/.local" and reboot

When attaching GDB to the running gnunet-fs-gtk process, the last line shows:
0x00007faf0a287c54 in uri_ksk_parse (emsg=0x7fff3c161a08,
 s=0xa567e0 "gnunet://fs/ksk/..... name of file + tags .....") at fs_uri.c:314
314 if ((s[i] == '%') && (&s[i] == strstr (&s[i], "%22")))
Steps To ReproduceCannot reproduce since gnunet-fs-gtk won't run anymore, but this is how I caused it:

1. Start gnunet-gtk on a remote host with X-forwarding over SSH.
2. Share 2 big files ( 2x ~700MB) with anonymity level 10
3. Index the files till 0000013:0000010%.
4. CRTL^C gnunet-gtk (it didn't seem to return to the terminal)
5. Reboot the remote host, Gnunet will still run on the server.
6. Start gnunet-gtk on the remote host with X-forwarding over SSH.
TagsNo tags attached.

Activities

Christian Grothoff

2014-01-16 13:22

manager   ~0007998

Fixed in SVN 31931, bad cmp between signed and unsigned integer.
You should be able to recover by applying the following change
against the src/fs/fs_uri.c code:

Index: fs_uri.c
===================================================================
--- fs_uri.c (revision 31879)
+++ fs_uri.c (working copy)
@@ -309,7 +309,7 @@
   iret = max;
   dup = GNUNET_strdup (s);
   keywords = GNUNET_malloc (max * sizeof (char *));
- for (i = slen - 1; i >= pos; i--)
+ for (i = slen - 1; i >= (int) pos; i--)
   {
     if ((s[i] == '%') && (&s[i] == strstr (&s[i], "%22")))
     {

Issue History

Date Modified Username Field Change
2014-01-16 01:07 snowwie New Issue
2014-01-16 13:22 Christian Grothoff Note Added: 0007998
2014-01-16 13:22 Christian Grothoff Assigned To => Christian Grothoff
2014-01-16 13:22 Christian Grothoff Status new => assigned
2014-01-16 13:22 Christian Grothoff Status assigned => resolved
2014-01-16 13:22 Christian Grothoff Fixed in Version => 0.10.1
2014-01-16 13:22 Christian Grothoff Resolution open => fixed
2014-01-16 13:22 Christian Grothoff Target Version => 0.10.1
2014-04-08 16:42 Christian Grothoff Status resolved => closed