View Issue Details

IDProjectCategoryView StatusLast Update
0003250gnunet-gtkbuild systempublic2014-04-08 16:42
ReportertaylanubAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD64OSOpenBSDOS Version5.3
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003250: IN6_IS_ADDR_LINKLOCAL usage errors
DescriptionThe usage of the IN6_IS_ADDR_LINKLOCAL macro in gnunet-setup-transport.c:346 (function nipo) leads to the error "'const struct sockaddr' has no member named '__u6_addr'" on my OpenBSD 5.3. I don't know why.
Steps To Reproduce./configure && make
Additional InformationI ""fixed"" the issue for me by commenting out the whole if statement since it tests for IPv6 and I don't use IPv6 yet. Probably not a good solution.
TagsNo tags attached.

Activities

Christian Grothoff

2014-01-04 03:27

manager   ~0007962

I suspect the FreeBSD macro simply requires a cast to the IPv6 struct first. Added that in SVN 31788.

Issue History

Date Modified Username Field Change
2014-01-04 01:01 taylanub New Issue
2014-01-04 03:27 Christian Grothoff Note Added: 0007962
2014-01-04 03:27 Christian Grothoff Status new => resolved
2014-01-04 03:27 Christian Grothoff Fixed in Version => 0.10.1
2014-01-04 03:27 Christian Grothoff Resolution open => fixed
2014-01-04 03:27 Christian Grothoff Assigned To => Christian Grothoff
2014-01-04 03:27 Christian Grothoff Target Version => 0.10.1
2014-04-08 16:42 Christian Grothoff Status resolved => closed