View Issue Details

IDProjectCategoryView StatusLast Update
0003248GNUnetTCP transportpublic2014-04-08 16:42
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003248: NPE
Description==8113== Invalid write of size 8
==8113== at 0x568F730: GNUNET_SERVER_client_set_user_context_ (server.c:378)
==8113== by 0x9099FE4: tcp_disconnect_session (plugin_transport_tcp.c:809)
==8113== by 0x909D7D2: tcp_plugin_get_session (plugin_transport_tcp.c:1584)
==8113== by 0x415E89: transmit_ping_if_allowed (gnunet-service-transport_validation.c:552)
==8113== by 0x407742: GST_blacklist_test_allowed (gnunet-service-transport_blacklist.c:735)
==8113== by 0x414FCE: revalidate_address (gnunet-service-transport_validation.c:687)
==8113== by 0x568EDF1: GNUNET_SCHEDULER_run (scheduler.c:595)
==8113== by 0x5698829: GNUNET_SERVICE_run (service.c:1490)
==8113== by 0x403628: main (gnunet-service-transport.c:1015)
==8113== Address 0x78 is not stack'd, malloc'd or (recently) free'd
==8113==
==8113==
==8113== Process terminating with default action of signal 11 (SIGSEGV): dumping core
==8113== Access not within mapped region at address 0x78
==8113== at 0x568F730: GNUNET_SERVER_client_set_user_context_ (server.c:378)
==8113== by 0x9099FE4: tcp_disconnect_session (plugin_transport_tcp.c:809)
==8113== by 0x909D7D2: tcp_plugin_get_session (plugin_transport_tcp.c:1584)
==8113== by 0x415E89: transmit_ping_if_allowed (gnunet-service-transport_validation.c:552)
==8113== by 0x407742: GST_blacklist_test_allowed (gnunet-service-transport_blacklist.c:735)
==8113== by 0x414FCE: revalidate_address (gnunet-service-transport_validation.c:687)
==8113== by 0x568EDF1: GNUNET_SCHEDULER_run (scheduler.c:595)
==8113== by 0x5698829: GNUNET_SERVICE_run (service.c:1490)
==8113== by 0x403628: main (gnunet-service-transport.c:1015)
TagsNo tags attached.

Relationships

duplicate of 0003245 closedChristian Grothoff crash in TCP plugin 

Activities

Christian Grothoff

2014-01-02 14:19

manager   ~0007958

SVN 31780.

Issue History

Date Modified Username Field Change
2014-01-02 11:45 Christian Grothoff New Issue
2014-01-02 11:45 Christian Grothoff Status new => assigned
2014-01-02 11:45 Christian Grothoff Assigned To => Matthias Wachs
2014-01-02 14:19 Christian Grothoff Note Added: 0007958
2014-01-02 14:19 Christian Grothoff Status assigned => resolved
2014-01-02 14:19 Christian Grothoff Fixed in Version => 0.10.1
2014-01-02 14:19 Christian Grothoff Resolution open => fixed
2014-01-02 14:19 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2014-01-02 20:18 amatus Relationship added duplicate of 0003245
2014-04-08 16:42 Christian Grothoff Status resolved => closed