View Issue Details

IDProjectCategoryView StatusLast Update
0003226GNUnettun librarypublic2014-04-08 16:42
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003226: regex generated for port spec "!25" is too large
DescriptionThe current code generates a massive regex, which is then too large to be processed by the code (IPC message > 64k). This is because the code fails to properly optimize the regex and instead lists 64k-1 combinations.
Steps To ReproduceSet exit policy to "all but port 25" and watch exit service die on startup due to too-large regex.
TagsNo tags attached.

Activities

Christian Grothoff

2014-01-12 21:19

manager   ~0007983

Implemented in SVN 31880.

Issue History

Date Modified Username Field Change
2013-12-20 15:32 Christian Grothoff New Issue
2013-12-23 19:07 Christian Grothoff Assigned To => Christian Grothoff
2013-12-23 19:07 Christian Grothoff Status new => assigned
2014-01-12 21:19 Christian Grothoff Note Added: 0007983
2014-01-12 21:20 Christian Grothoff Status assigned => resolved
2014-01-12 21:20 Christian Grothoff Fixed in Version => 0.10.1
2014-01-12 21:20 Christian Grothoff Resolution open => fixed
2014-01-12 21:20 Christian Grothoff Product Version SVN HEAD => 0.10.0
2014-04-08 16:42 Christian Grothoff Status resolved => closed