View Issue Details

IDProjectCategoryView StatusLast Update
0003155GNUnetDV service or transportpublic2013-12-24 20:54
ReporterMatthias WachsAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.0Fixed in Version0.10.0 
Summary0003155: Crash in shutdown
Description^CDec 05 10:07:03-845433 test-transport-dv-23526 ERROR Controller crash detected. Shutting down.
==23562== Invalid read of size 8
==23562== at 0x56740B8: find_section (configuration.c:683)
==23562== by 0x567411A: find_entry (configuration.c:706)
==23562== by 0x56746E9: GNUNET_CONFIGURATION_get_value_string (configuration.c:955)
==23562== by 0x56755A8: GNUNET_CONFIGURATION_get_value_filename (configuration.c:1265)
==23562== by 0x566C328: test_service_configuration (client.c:302)
==23562== by 0x566C7D3: GNUNET_CLIENT_connect (client.c:414)
==23562== by 0x54556C3: reconnect (core_api.c:1076)
==23562== by 0x5450985: reconnect_task (core_api.c:354)
==23562== by 0x56A6DD0: run_ready (scheduler.c:593)
==23562== by 0x56A7657: GNUNET_SCHEDULER_run (scheduler.c:808)
==23562== by 0x56B56DA: GNUNET_SERVICE_run (service.c:1478)
==23562== by 0x4067D3: main (gnunet-service-dv.c:2085)
==23562== Address 0x0 is not stack'd, malloc'd or (recently) free'd
==23562==
==23562==
==23562== Process terminating with default action of signal 11 (SIGSEGV): dumping core
==23562== Access not within mapped region at address 0x0
==23562== at 0x56740B8: find_section (configuration.c:683)
==23562== by 0x567411A: find_entry (configuration.c:706)
==23562== by 0x56746E9: GNUNET_CONFIGURATION_get_value_string (configuration.c:955)
==23562== by 0x56755A8: GNUNET_CONFIGURATION_get_value_filename (configuration.c:1265)
==23562== by 0x566C328: test_service_configuration (client.c:302)
==23562== by 0x566C7D3: GNUNET_CLIENT_connect (client.c:414)
==23562== by 0x54556C3: reconnect (core_api.c:1076)
==23562== by 0x5450985: reconnect_task (core_api.c:354)
==23562== by 0x56A6DD0: run_ready (scheduler.c:593)
==23562== by 0x56A7657: GNUNET_SCHEDULER_run (scheduler.c:808)
==23562== by 0x56B56DA: GNUNET_SERVICE_run (service.c:1478)
==23562== by 0x4067D3: main (gnunet-service-dv.c:2085)
==23562== If you believe this happened as a result of a stack
Steps To Reproducerun test
TagsNo tags attached.

Relationships

duplicate of 0003152 closedChristian Grothoff Dynamic growing consensus set causes segfault 
child of 0001795 confirmed DV is not implemented 

Activities

Christian Grothoff

2013-12-08 22:20

manager   ~0007786

I'm pretty sure that this is just another way how the issue 0003152 (fixed in SVN 31167) can materialize, as in 31167 an overflow might clobber the coreAPI pointer, and in that location we store the *cfg at offset zero, so that can easily get hit as well (and cfg being NULL causes this crash).

Issue History

Date Modified Username Field Change
2013-12-05 10:14 Matthias Wachs New Issue
2013-12-05 10:14 Matthias Wachs Assigned To => Matthias Wachs
2013-12-05 10:14 Matthias Wachs Status new => assigned
2013-12-06 00:08 Christian Grothoff Product Version => SVN HEAD
2013-12-06 00:08 Christian Grothoff Target Version => 0.10.0
2013-12-07 22:20 Christian Grothoff Relationship added child of 0001795
2013-12-08 22:19 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2013-12-08 22:20 Christian Grothoff Note Added: 0007786
2013-12-08 22:20 Christian Grothoff Relationship added duplicate of 0003152
2013-12-08 22:20 Christian Grothoff Status assigned => resolved
2013-12-08 22:20 Christian Grothoff Fixed in Version => 0.10.0
2013-12-08 22:20 Christian Grothoff Resolution open => fixed
2013-12-24 20:54 Christian Grothoff Status resolved => closed