View Issue Details

IDProjectCategoryView StatusLast Update
0003131GNUnetcadet servicepublic2013-12-24 20:54
ReporterFlorian DoldAssigned ToBart Polot 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.10.0Fixed in Version0.10.0 
Summary0003131: mesh crash causes consensus to fail
Descriptiondold@dold-x1c:~/repos/gnunet/src/consensus$ GNUNET_FORCE_LOG="set;;;;DEBUG/mesh;;;;DEBUG" gnunet-consensus-profiler -c test_consensus.conf

The mesh service disconnects the mesh api (because it crashes), and the mesh api does not notify the consensus service of the failure (it still tries to reconnect, but that break's the protocol (see 2966).
Additional InformationLogs:

[...]
Nov 26 15:17:31-189782 mesh-p2p-5071 DEBUG calling core tmt rdy towards 6ULB for 72 bytes
Nov 26 15:17:31-189797 mesh-con-5071 DEBUG Connection QHC01C99 (->6ULB) state was MESH_CONNECTION_SENT
Nov 26 15:17:31-189807 mesh-con-5071 DEBUG Connection QHC01C99 (->6ULB) state is now MESH_CONNECTION_SENT
Nov 26 15:17:31-189817 mesh-con-5071 DEBUG Connection QHC01C99 (->6ULB) state was MESH_CONNECTION_SENT
Nov 26 15:17:31-189826 mesh-con-5071 DEBUG Connection QHC01C99 (->6ULB) state is now MESH_CONNECTION_ACK
Nov 26 15:17:31-190177 mesh-api-5069 DEBUG Mesh service disconnected, reconnecting

now the core of the crashed mesh service:
(gdb) bt
#0 0x00007fb7d5f50052 in GNUNET_PEER_decrement_rcs () from /home/dold/lib/libgnunetutil.so.9
#1 0x0000000000420f47 in path_duplicate ()
#2 0x000000000040c804 in GMC_handle_create ()
#3 0x00007fb7d5d04a8a in main_notify_handler () from /home/dold/lib/libgnunetcore.so.0
#4 0x00007fb7d5f1d0a6 in receive_task () from /home/dold/lib/libgnunetutil.so.9
#5 0x00007fb7d5f56549 in run_ready () from /home/dold/lib/libgnunetutil.so.9
#6 0x00007fb7d5f56dd1 in GNUNET_SCHEDULER_run () from /home/dold/lib/libgnunetutil.so.9
#7 0x00007fb7d5f64d99 in GNUNET_SERVICE_run () from /home/dold/lib/libgnunetutil.so.9
#8 0x00000000004216a0 in run ()
TagsNo tags attached.

Relationships

duplicate of 0003123 closedBart Polot Crash in path_destroy 
related to 0002966 closedBart Polot mesh's behavior on client-service disconnect breaks stateful protocols 
related to 0001795 confirmed DV is not implemented 

Activities

Bart Polot

2013-11-26 16:35

manager   ~0007709

Fixed in 30875.

Issue History

Date Modified Username Field Change
2013-11-26 15:25 Florian Dold New Issue
2013-11-26 15:25 Florian Dold Status new => assigned
2013-11-26 15:25 Florian Dold Assigned To => Bart Polot
2013-11-26 15:25 Florian Dold Relationship added related to 0002966
2013-11-26 15:33 Florian Dold Relationship added related to 0001795
2013-11-26 16:35 Bart Polot Note Added: 0007709
2013-11-26 16:35 Bart Polot Relationship added duplicate of 0003123
2013-11-26 16:35 Bart Polot Status assigned => resolved
2013-11-26 16:35 Bart Polot Fixed in Version => SVN HEAD
2013-11-26 16:35 Bart Polot Resolution open => duplicate
2013-11-26 23:40 Christian Grothoff Product Version => SVN HEAD
2013-11-26 23:40 Christian Grothoff Fixed in Version SVN HEAD => 0.10.0
2013-11-26 23:40 Christian Grothoff Target Version => 0.10.0
2013-12-24 20:54 Christian Grothoff Status resolved => closed
2014-05-09 18:34 Christian Grothoff Category mesh service => cadet service