View Issue Details

IDProjectCategoryView StatusLast Update
0003036gnunet-gtkgnunet-fs-gtkpublic2013-12-24 20:54
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.0Fixed in Version0.10.0 
Summary0003036: trying to closing main gnunet-fs-gtk window while dialog is open hangs application
DescriptionThis is likely because then the shutdown sequence does not work properly. We should probably simply disallow closing the main window while any dialog is open. Note that due to our hijacking of the gtk event loop we cannot just make dialogs modal in GTK.
TagsNo tags attached.

Activities

Christian Grothoff

2013-10-07 11:48

manager   ~0007492

Easily fixed by setting all dialog's "modal" flag to TRUE.

Christian Grothoff

2013-10-07 11:49

manager   ~0007493

Fixed in SVN 29919.

Issue History

Date Modified Username Field Change
2013-09-15 18:45 Christian Grothoff New Issue
2013-09-15 21:47 Christian Grothoff Status new => confirmed
2013-09-15 21:47 Christian Grothoff Priority normal => urgent
2013-09-15 21:47 Christian Grothoff Target Version => 0.10.1
2013-09-22 17:47 Christian Grothoff Assigned To => Christian Grothoff
2013-09-22 17:47 Christian Grothoff Status confirmed => assigned
2013-10-07 11:48 Christian Grothoff Note Added: 0007492
2013-10-07 11:48 Christian Grothoff Status assigned => resolved
2013-10-07 11:48 Christian Grothoff Fixed in Version => 0.10.0
2013-10-07 11:48 Christian Grothoff Resolution open => fixed
2013-10-07 11:49 Christian Grothoff Note Added: 0007493
2013-10-07 11:49 Christian Grothoff Target Version 0.10.1 => 0.10.0
2013-12-24 20:54 Christian Grothoff Status resolved => closed