View Issue Details

IDProjectCategoryView StatusLast Update
0002903libextractorlibextractor main librarypublic2013-06-29 22:15
ReporterbrataoAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformW32OSWindowsOS Version8
Product Version1.0.1 
Target Version1.1Fixed in Version1.1 
Summary0002903: Files with big metadata fail to parse using gnunet-helper-fs-publish
DescriptionI have a mp3 file that gnunet can´t read, but extract.exe or gnunet-helper-fs-publish alone can.
By logging gnunet-helper-fs-publish and fs_dirmetascan I can see that ¨Helper sends 50732-byte message of type 425¨ but ¨DMS parses 22377-byte message of type 27756¨ and fails.

I would guess that we reading the buffer before we finshed writing.As we read a message with type 27756 when we supposed to get a message with type 425 (GNUNET_MESSAGE_TYPE_FS_PUBLISH_HELPER_META_DATA)


TagsNo tags attached.

Relationships

has duplicate 0004136 closedChristian Grothoff GNUnet Starting "gnunet-publish -e" causes a crash 

Activities

Christian Grothoff

2013-06-25 12:23

manager   ~0007170

Could you share the test file with me?

Christian Grothoff

2013-06-25 14:44

manager   ~0007171

I found an issue within LE today that causes meta data to be lost (LE fails).
The issue is timing-dependent; for me, it showed up if the file was not cached in memory or when I ran the command-line tool in a for loop for a while. So it is possible that it showed with gnunet-fs-gtk and not extract for you. W32 and GNU systems were both affected. So please also try to reproduce with SVN HEAD of LE.

bratao

2013-06-25 15:54

developer   ~0007172

Yeah ! That was exactly the problem !

bratao

2013-06-26 00:43

developer   ~0007184

Christian,
I double checked and this bug is still occurring. It is an IPC error.

I sent to your email as its a private file.

Christian Grothoff

2013-06-26 11:47

manager   ~0007189

The gstreamer plugin was writing to stdout, causing the IPC to fail as that also uses stdin/stdout. Fixed in SVN 27612.

Issue History

Date Modified Username Field Change
2013-06-22 00:05 bratao New Issue
2013-06-25 12:11 Christian Grothoff Assigned To => Christian Grothoff
2013-06-25 12:11 Christian Grothoff Status new => assigned
2013-06-25 12:23 Christian Grothoff Note Added: 0007170
2013-06-25 14:44 Christian Grothoff Note Added: 0007171
2013-06-25 14:44 Christian Grothoff Status assigned => feedback
2013-06-25 15:54 bratao Note Added: 0007172
2013-06-25 15:54 bratao Status feedback => assigned
2013-06-25 15:54 bratao Status assigned => resolved
2013-06-25 15:54 bratao Resolution open => fixed
2013-06-25 16:13 Christian Grothoff Project GNUnet => libextractor
2013-06-25 16:13 Christian Grothoff Category file-sharing service => General
2013-06-25 16:14 Christian Grothoff Category General => libextractor main library
2013-06-25 16:14 Christian Grothoff Product Version SVN HEAD => current SVN
2013-06-25 16:14 Christian Grothoff Fixed in Version => current SVN
2013-06-25 16:14 Christian Grothoff Target Version => current SVN
2013-06-25 16:15 Christian Grothoff Product Version current SVN => 1.0.1
2013-06-25 16:15 Christian Grothoff Fixed in Version current SVN => 1.1
2013-06-25 16:15 Christian Grothoff Target Version current SVN => 1.1
2013-06-26 00:43 bratao Note Added: 0007184
2013-06-26 00:43 bratao Status resolved => feedback
2013-06-26 00:43 bratao Resolution fixed => reopened
2013-06-26 11:47 Christian Grothoff Note Added: 0007189
2013-06-26 11:47 Christian Grothoff Status feedback => resolved
2013-06-26 11:47 Christian Grothoff Resolution reopened => fixed
2013-06-29 22:15 Christian Grothoff Status resolved => closed
2016-02-02 19:28 Christian Grothoff Relationship added has duplicate 0004136