View Issue Details

IDProjectCategoryView StatusLast Update
0002838GNUnettransport servicepublic2013-12-24 20:55
ReporterChristian GrothoffAssigned ToMatthias Wachs 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.0Fixed in Version0.10.0 
Summary0002838: need ability to blacklist a particular plugin for a particular connection between peers in configuration
DescriptionIn 0.8, we could say "no TCP between peer X and Y". Having this ability again,
and in particular having it in the configuration (not "just" via some API) would
be very useful, especially for DV testing as there we can then just enable
TCP+DV and blacklist some TCP connections and still expect testbed to construct a clique -- making the testcase code itself nice & trivial.
TagsNo tags attached.

Relationships

child of 0001795 confirmed DV is not implemented 

Activities

Christian Grothoff

2013-03-27 10:30

manager   ~0007014

read_blacklist_file () would just need to be changed to use blacklist directly from cfg section instead. -- and maybe documented better...

Matthias Wachs

2013-03-27 17:33

manager   ~0007015

implemented in 26619.

We now support:
Adding a cfg section for a peer containing blacklisted peer + transports

Example:
On AG2P... blacklist connections to P565... on tcp:

[transport-blacklist-AG2PHES1BARB9IJCPAMJTFPVJ5V3A72S3F2A8SBUB8DAQ2V0O3V8G6G2JU56FHGFOHMQVKBSQFV98TCGTC3RJ1NINP82G0RC00N1520]
P565723JO1C2HSN6J29TAQ22MN6CI8HTMUU55T0FUQG4CMDGGEQ8UCNBKUMB94GC8R9G4FB2SF9LDOBAJ6AMINBP4JHHDD6L7VD801G = tcp

On AG2P... blacklist connections to P565... on all transports:

[transport-blacklist-AG2PHES1BARB9IJCPAMJTFPVJ5V3A72S3F2A8SBUB8DAQ2V0O3V8G6G2JU56FHGFOHMQVKBSQFV98TCGTC3RJ1NINP82G0RC00N1520]
P565723JO1C2HSN6J29TAQ22MN6CI8HTMUU55T0FUQG4CMDGGEQ8UCNBKUMB94GC8R9G4FB2SF9LDOBAJ6AMINBP4JHHDD6L7VD801G =

Christian Grothoff

2013-03-27 21:00

manager   ~0007016

The new option doesn't seem to work:

I've added the respective options to test_transport_dv_data.conf; however, despite one connection being forbidden in both directions, I still see the peers connect via TCP (gnunet-statistics, after changing if (1) to if (0) in test_transport_api_dv) and no DV seems to be used (still testbed claims to create a clique).

Matthias Wachs

2013-03-28 13:54

manager   ~0007017

2 major fixes in blacklisting in 26633:

- connection was disallowed if any blacklist entry was existing
- plugin specific blacklist entry was added with empty string

Added 6 new testcases in transport testing in/outbound blacklisting on peer and plugin bases

-> working for me

Issue History

Date Modified Username Field Change
2013-03-18 13:01 Christian Grothoff New Issue
2013-03-18 13:01 Christian Grothoff Status new => assigned
2013-03-18 13:01 Christian Grothoff Assigned To => Matthias Wachs
2013-03-18 13:01 Christian Grothoff Relationship added child of 0001795
2013-03-27 10:30 Christian Grothoff Note Added: 0007014
2013-03-27 17:33 Matthias Wachs Note Added: 0007015
2013-03-27 17:34 Matthias Wachs Status assigned => resolved
2013-03-27 17:34 Matthias Wachs Resolution open => fixed
2013-03-27 21:00 Christian Grothoff Note Added: 0007016
2013-03-27 21:00 Christian Grothoff Status resolved => feedback
2013-03-27 21:00 Christian Grothoff Resolution fixed => reopened
2013-03-27 21:01 Christian Grothoff Status feedback => assigned
2013-03-28 13:54 Matthias Wachs Note Added: 0007017
2013-03-28 13:55 Matthias Wachs Status assigned => resolved
2013-03-28 13:55 Matthias Wachs Resolution reopened => fixed
2013-04-01 18:08 Christian Grothoff Fixed in Version => 0.10.0
2013-04-01 18:08 Christian Grothoff Target Version => 0.10.0
2013-12-24 20:55 Christian Grothoff Status resolved => closed