View Issue Details

IDProjectCategoryView StatusLast Update
0002492gnunet-gtkgnunet-setuppublic2012-12-21 16:47
ReporterMatthias WachsAssigned ToChristian Grothoff 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.9.5Fixed in Version0.9.5 
Summary0002492: records are immediately deleted on right click
DescriptionOn my crappy notebook touchpad records are immediately deleted when i right click.

How it should work:
First right click: open context menu then select item the click again
How it works:
Right click selects delete and record is deleted
TagsNo tags attached.

Relationships

related to 0002465 closedChristian Grothoff need dedicated dialogs for editing GNS records 

Activities

schanzen

2012-07-09 16:45

reporter   ~0006228

This also happens on my notebook with a mouse *sometimes*. But it is annoying. When you hold the button you can also select other options... but it's not how it's mean to be (TM)

Matthias Wachs

2012-07-10 08:18

manager   ~0006230

Definitely ... it's a touchpad issue ... if you hold the button you can select another options ... but here the items are immeditely deleted without confirmation

Christian Grothoff

2012-07-10 09:01

manager   ~0006231

Eh, we're not really doing anything unusual here, all of this is gtk+-specific behavior. So I'm not sure if this should be a bug filed against gtk+, if we should just change our menu order to avoid having 'delete' on top, or if there is something else we can (and should) really do. Also, I don't have this problem, either because I have a better mouse or because I'm more agile ;-)

Christian Grothoff

2012-12-03 09:23

manager   ~0006623

Delete option in context menu is now gone, so this won't be a problem anymore.

Issue History

Date Modified Username Field Change
2012-07-09 13:49 Matthias Wachs New Issue
2012-07-09 16:45 schanzen Note Added: 0006228
2012-07-10 08:18 Matthias Wachs Note Added: 0006230
2012-07-10 09:01 Christian Grothoff Note Added: 0006231
2012-08-30 20:49 Christian Grothoff Severity feature => tweak
2012-11-06 23:31 Christian Grothoff Target Version => 0.9.5
2012-11-06 23:39 Christian Grothoff Assigned To => Christian Grothoff
2012-11-06 23:39 Christian Grothoff Status new => assigned
2012-11-10 22:41 Christian Grothoff Relationship added related to 0002465
2012-12-03 09:23 Christian Grothoff Note Added: 0006623
2012-12-03 09:23 Christian Grothoff Status assigned => resolved
2012-12-03 09:23 Christian Grothoff Fixed in Version => 0.9.5
2012-12-03 09:23 Christian Grothoff Resolution open => fixed
2012-12-21 16:47 Christian Grothoff Status resolved => closed