View Issue Details

IDProjectCategoryView StatusLast Update
0001643libextractorbuild systempublic2012-09-09 02:35
ReporteranderslmAssigned Toholin 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.6.1 
Target Version1.0.0Fixed in Version1.0.0 
Summary0001643: Can't build due to ffmpeg now use UINT64_C.
DescriptionRecent versions of ffmpeg is now using UINT64_C in libavutil/common.h.
The current svn head can't build due to this.

I have created a trivial patch to fix this.

To reproduce:
Install ffmpeg-0.6.1
./configure --enable-ffmpeg
make
TagsNo tags attached.

Activities

2011-01-09 22:22

 

libextractor-build-with-recent-ffmpeg.patch (316 bytes)
Index: configure.ac
===================================================================
--- configure.ac	(revision 14121)
+++ configure.ac	(working copy)
@@ -441,6 +441,7 @@
 QT_LDFLAGS=$LDFLAGS
 LDFLAGS=$SAVED_LDFLAGS
 CPPFLAGS=$SAVED_CPPFLAGS
+CPPFLAGS="$CPPFLAGS -D__STDC_CONSTANT_MACROS"
 
 # end C++ checks
 fi

holin

2011-01-10 20:24

developer   ~0004228

The problem was a different one. Should be fixed in r14135.

Issue History

Date Modified Username Field Change
2011-01-09 22:22 anderslm New Issue
2011-01-09 22:22 anderslm File Added: libextractor-build-with-recent-ffmpeg.patch
2011-01-10 20:23 holin Status new => assigned
2011-01-10 20:23 holin Assigned To => holin
2011-01-10 20:24 holin Note Added: 0004228
2011-01-10 20:24 holin Status assigned => resolved
2011-01-10 20:24 holin Fixed in Version => current SVN
2011-01-10 20:24 holin Resolution open => fixed
2011-04-27 16:18 Christian Grothoff Status resolved => closed
2012-09-09 02:35 Christian Grothoff Fixed in Version current SVN => 1.0.0
2012-09-09 02:35 Christian Grothoff Target Version => 1.0.0