View Issue Details

IDProjectCategoryView StatusLast Update
0008921Talerwallet (WebExtension)public2024-06-17 20:55
ReporterFlorian Dold Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.12 
Summary0008921: allow retrying after scanning (peer-push-credit) QR code [2hs]
DescriptionWhen scanning a (peer-push-credit) QR code and the `check*` wallet-core call fails, the user needs to re-scan the QR code.

That doesn't quite work when the other user already ran away and there's no way to scan the QR code anymore.

There should be an option to retry based on the UI, because there is no wallet-core transaction for the QR code yet.

estimation: we can do this by creating a generic view [retry], it will call the main hook.retry() function.
 - testing the approach work [1hs]
 - implement on every CTA [1hs]
TagsNo tags attached.

Activities

sebasjm

2024-06-17 20:55

developer   ~0022654

added a retry operation button on commit ea870c419

still the same effect can also be achieved with browser refresh since the taler URI is in the URL

Issue History

Date Modified Username Field Change
2024-06-10 23:10 Florian Dold New Issue
2024-06-10 23:10 Florian Dold Status new => assigned
2024-06-10 23:10 Florian Dold Assigned To => Florian Dold
2024-06-10 23:11 Florian Dold Issue cloned: 0008922
2024-06-10 23:12 Florian Dold Assigned To Florian Dold => sebasjm
2024-06-16 22:47 sebasjm Summary allow retrying after scanning (peer-push-credit) QR code => allow retrying after scanning (peer-push-credit) QR code [2hs]
2024-06-16 22:47 sebasjm Description Updated
2024-06-17 20:55 sebasjm Status assigned => resolved
2024-06-17 20:55 sebasjm Resolution open => fixed
2024-06-17 20:55 sebasjm Note Added: 0022654