View Issue Details

IDProjectCategoryView StatusLast Update
0008869Talerwallet-corepublic2024-06-16 17:59
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Target Version0.12 
Summary0008869: try to reproduce OOM of wallet-core when making certain p2p payments
DescriptionChristian ran into an OOM situation in wallet-core when making many (350) small p2p payments and then doing one big p2p payments with the resulting change.

This final p2p payment got aborted (manually), and somehow the wallet used up lots of memory, resulting in a crash due to OOM.
TagsNo tags attached.

Activities

Florian Dold

2024-06-16 17:59

manager   ~0022625

commit e00ecc6d717fe9a37e35a95d552ab982808377f8 (HEAD -> master, origin/master, origin/HEAD)
Author: Florian Dold <florian@dold.me>
Date: Sun Jun 16 17:58:34 2024 +0200

    wallet-core: process sessions in refresh group sequentially
    
    Otherwise we can easily run in the situation where we make a lot of
    crypto and network requests in parallel, never really making progress,
    because we go OOM before the results are committed to the DB.

Issue History

Date Modified Username Field Change
2024-05-27 12:53 Florian Dold New Issue
2024-05-27 12:53 Florian Dold Status new => assigned
2024-05-27 12:53 Florian Dold Assigned To => Florian Dold
2024-06-16 17:59 Florian Dold Status assigned => resolved
2024-06-16 17:59 Florian Dold Resolution open => fixed
2024-06-16 17:59 Florian Dold Note Added: 0022625