View Issue Details

IDProjectCategoryView StatusLast Update
0008733Talerexchangepublic2024-05-13 21:19
Reportersebasjm Assigned ToChristian Grothoff  
PriorityhighSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Product Version0.10 
Target Version0.13 
Summary0008733: wallet don't get money after completing KYC
Descriptionhappens locally,
1.- start a withdrawal that requires KYC
2.- start challenge
3.- set TAN code
4.- close the confirmation page

expect money arrive but money never arrives to the wallet, found some errors in exchange-httpd's journal

also, if I try another withdrawal from same bank account the money arrives correctly

challenger needs git revision in the help command!!
$ challenger-httpd --version
challenger-httpd v0.10.0

Built from commit 9d3b51d1301a79f4126c74fa8df0811221a8fda2

$ taler-exchange-httpd --version
taler-exchange-httpd v0.10.1-git-e80e3d496



AH9MEGQK8RXSM) INFO HTTP request for `http://challenger.taler.test:1180/info' finished with 200 after 426 ┬Ás
AH9MEGQK8RXSM) INFO Conversion helper exited with status 3 and code 0 after outputting 100 bytes of data
AH9MEGQK8RXSM) INFO KYC process #3 succeeded with KYC provider
AH9MEGQK8RXSM) INFO Trying to start child management.
AH9MEGQK8RXSM) INFO Conversion helper exited with status 3 and code 1 after outputting 0 bytes of data
AH9MEGQK8RXSM) WARNING External protocol violation detected at json_helper.c:273.
AH9MEGQK8RXSM) WARNING Parsing failed for field `full_name:0`
AH9MEGQK8RXSM) ERROR Assertion failed at util.c:432.
TagsNo tags attached.

Activities

Christian Grothoff

2024-04-12 00:52

manager   ~0022214

KYC isn't for 0.10. Also, might just be a configuration issue, will need to investigate...

Christian Grothoff

2024-04-12 01:35

manager   ~0022216

The errors look like your KYC setup simply doesn't provide the required attributes, especially the "full_name" doesn't seem to be a string!?

sebasjm

2024-04-12 04:04

developer   ~0022220

full_name was .address, which for the challenger is an object. After fixing the log error goes away but the problem persist.

I found out that I have AML_THRESHOLD = NETZBON:10, account was pending and after putting it into normal state the TX completes.

What is funny is that the second withdrawal can go throught even if the first is being locked :)

Issue History

Date Modified Username Field Change
2024-04-11 23:40 sebasjm New Issue
2024-04-11 23:40 sebasjm Status new => assigned
2024-04-11 23:40 sebasjm Assigned To => Christian Grothoff
2024-04-11 23:42 sebasjm Description Updated
2024-04-12 00:52 Christian Grothoff Target Version 0.10 => 0.11
2024-04-12 00:52 Christian Grothoff Note Added: 0022214
2024-04-12 01:35 Christian Grothoff Note Added: 0022216
2024-04-12 04:04 sebasjm Note Added: 0022220
2024-05-05 15:42 Christian Grothoff Target Version 0.11 => 0.14
2024-05-13 21:19 Christian Grothoff Target Version 0.14 => 0.13