View Issue Details

IDProjectCategoryView StatusLast Update
0007818Talerwallet-corepublic2023-11-14 14:29
ReporterMarcS Assigned ToMarcS  
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.9.4 
Summary0007818: fractionalBaseDigits of currencies
DescriptionMost currencies in the world have two digits after the decimal point/comma - but some have three (most arabian countries: Bahraini Dinar, Iraqi Dinar, Jordanian Dinar, Kuwaiti Dinar, Libyan Dinar, Rial Omani, Tunisian Dinar) and some have none (Indonesian Rupiah, Japanese Yen, South-Korean Won, Vietnamese New Dong, Cape Verdi Escudo, Paraguay Guarani, and a few african and caribbean countries).

When querying for exchanges, the data returned should not only tell the name of the currency:
    var exchangeBaseUrl: String
    var currency: String?
but also the fractionalBaseDigits:
    var fractionalBaseDigits: UInt?

There are 3 possible wallet-core calls where that information could be returned:
1) ListExchangesOp
2) GetExchangeDetailedInfoOp
3) ListCurrenciesOp

Sebastian wrote about using denominations to find out what amount might be possible to send, but fractionalBaseDigits are needed to display amounts correctly in balances and transaction views, especially whole numbers which might still need to be shown with decimal delimiter and fractional digits (.00, .000, ...).
TagsNo tags attached.

Activities

Florian Dold

2023-11-14 14:02

manager   ~0020641

@MarcS: This looks like it's already covered by the currency spec, right?

MarcS

2023-11-14 14:29

developer   ~0020642

This is covered in DD51.

Issue History

Date Modified Username Field Change
2023-04-24 07:49 MarcS New Issue
2023-04-24 07:49 MarcS Status new => assigned
2023-04-24 07:49 MarcS Assigned To => Florian Dold
2023-08-24 16:27 Florian Dold Product Version post-1.0 => git (master)
2023-08-24 16:27 Florian Dold Target Version post-1.0 => 0.9.4
2023-11-14 14:02 Florian Dold Assigned To Florian Dold => MarcS
2023-11-14 14:02 Florian Dold Status assigned => feedback
2023-11-14 14:02 Florian Dold Note Added: 0020641
2023-11-14 14:29 MarcS Status feedback => resolved
2023-11-14 14:29 MarcS Resolution open => fixed
2023-11-14 14:29 MarcS Note Added: 0020642