View Issue Details

IDProjectCategoryView StatusLast Update
0007394Talerwallet (WebExtensions)public2022-11-18 22:42
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.9.1Fixed in Version0.9.1 
Summary0007394: weird behavior when service worker send a response to webex
Descriptionto reproduce:
add 2 exchanges for the same currency

https://exchange.taler.ar/
https://exchange-age.taler.ar/

start a withdrawal
click edit exchange
switch exchange and expect the comparison table

wallet-core response with the the fee details { ..., denomFees: {deposit, refresh, refund, withdraw} } which is ok

let obj be the response of the operation from wallet-core:
 1./* when the service worker receive the response from the wallet obj.result.denomFees.deposit has length 8
 2./* service worker prints the content of obj (https://git.taler.net/wallet-core.git/tree/packages/taler-wallet-webextension/src/platform/chrome.ts#n377)
 3./* then is sent to webex
 4./* webex receives it and print it out (https://git.taler.net/wallet-core.git/tree/packages/taler-wallet-webextension/src/platform/chrome.ts#n314)
 5./* obj.result.denomFees.deposit has length 23

it is the same operation since it have the same id.

The problem seems to be between 3 and 4 implying that the object get modified after is sent and before is received. But how is modified is consistent with what you would expect from "createTimeline" funciton in wallet-core so maybe the bug is in denomFees is constructed in function "getExchangeDetailedInfo"

Maybe shared object somewhere?
 
TagsNo tags attached.

Activities

sebasjm

2022-10-17 20:00

developer  

Selection_274.png (138,364 bytes)   
Selection_274.png (138,364 bytes)   

sebasjm

2022-11-18 15:32

developer   ~0019442

fixed at d8088e30da7048fb8fa79cc1aa1a3240513309c6

came back after a month and i was blind, i was using a impure function over an array

the issue is fixed

Issue History

Date Modified Username Field Change
2022-10-17 20:00 sebasjm New Issue
2022-10-17 20:00 sebasjm Status new => assigned
2022-10-17 20:00 sebasjm Assigned To => sebasjm
2022-10-17 20:00 sebasjm File Added: Selection_274.png
2022-10-20 11:31 Christian Grothoff Target Version 0.9 =>
2022-11-18 15:32 sebasjm Note Added: 0019442
2022-11-18 15:33 sebasjm Status assigned => resolved
2022-11-18 15:33 sebasjm Resolution open => fixed
2022-11-18 22:42 Christian Grothoff Target Version => 0.9.1
2022-11-18 22:42 Christian Grothoff Fixed in Version => 0.9.1