View Issue Details

IDProjectCategoryView StatusLast Update
0007353Talercashier (Android App)public2022-09-13 19:32
ReporterChristian Grothoff Assigned Togrote  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Summary0007353: cashier app timed out on withdraw attempt
DescriptionThe cashier app seems to implement a (also rather short!) timeout on the attempt to withdraw. We had a user that took some time to download the wallet (slow wifi), and then the QR code timed out on the cashier. This is bad, because IF the user had scanned it, and then the timeout hits, we'd be in a very inconsistent state. I think we should simply never timeout on the QR code and instead always require the user to manually abort.
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2022-09-08 20:57 Christian Grothoff New Issue
2022-09-08 20:57 Christian Grothoff Status new => assigned
2022-09-08 20:57 Christian Grothoff Assigned To => grote
2022-09-13 19:32 grote Status assigned => resolved
2022-09-13 19:32 grote Resolution open => fixed
2022-09-13 19:32 grote Note Added: 0019129