View Issue Details

IDProjectCategoryView StatusLast Update
0007323Talerwallet (TS core)public2022-09-12 16:00
ReporterFlorian Dold Assigned Tosebasjm  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0007323: spec wallet-core request to get exchange details
DescriptionCurrently, we get all exchange details via the listExchanges(Detailled) request.

This returns a *lot* of data, too much data for Android to handle.

We should have an API that *either*:

(a) returns the data in smaller chunks (paginated)
(b) returns the *processed* data that the UI will display

I think (b) is a good option, since all that processing logic doesn't really belong in the UI layer.
TagsNo tags attached.

Activities

sebasjm

2022-09-12 16:00

developer   ~0019124

after push fc413bb5..27201416 denomination info has been moved to getExchangeDetailedInfo

The information returned from wallet-core is grouped by operation as a timeline.
It should be less information and should not exceed Android limit.

Issue History

Date Modified Username Field Change
2022-09-05 21:04 Florian Dold New Issue
2022-09-05 21:04 Florian Dold Status new => assigned
2022-09-05 21:04 Florian Dold Assigned To => sebasjm
2022-09-12 16:00 sebasjm Note Added: 0019124
2022-09-12 16:00 sebasjm Status assigned => resolved
2022-09-12 16:00 sebasjm Resolution open => fixed