View Issue Details

IDProjectCategoryView StatusLast Update
0007247libeufinsandboxpublic2022-06-24 13:54
ReporterChristian Grothoff Assigned ToMS  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Fixed in Version0.1 
Summary0007247: cosmetic sandbox issues in CHF deployment...
Description1) Title always shows as "Demo bank". How can I customize that?
2) The Landing-bank-blog-donations-survey navbar always shows. If used outside of the demo, it would be good to hide that (but keep the language switcher!). How?
3) The text belwo "Demo bank" about "This part of the demo... Public Accounts" should be hidden if not run as part of the demo, ditto about the "To view transactions of public accounts" near the bottom.
4) If customer registration was disabled, the text about "please register" and registration being free should be hidden (not sure if it is or is not, I was unable to disable registration)
5) I get an error: "If you are a new customer please register! Registration is fast and free, and it gives you a registration bonus of 100 error: currency could not be retrieved" (note the "error: currency could not be retrieved"). I did set the currency to CHF in the sandbox configuration.
TagsNo tags attached.

Activities

ms-mantis

2022-05-19 08:05

reporter   ~0018906

On point 5.

That might be due to a miscommunication with the backend, as the currency is never hard-coded in the SPA.

ms-mantis

2022-05-26 12:07

reporter   ~0018907

On point 1.

Now option "--ui-title" from "libeufin-sandbox config" available.

ms-mantis

2022-05-26 12:14

reporter   ~0018908

On point 3.

How to decide that the bank is running a demo?

I suggest that the bank runs the demo only if the registration bonus is >0.

ms-mantis

2022-05-27 15:25

reporter   ~0018909

Recap:

1. Solved (see above)
2, 3. Are fulfilled when "--without-registration-bonus" was used.
4. Could not reproduce. Cached content getting in the way?
5. Responded above.

Christian Grothoff

2022-06-24 13:54

developer   ~0018934

Seems all better now.

Issue History

Date Modified Username Field Change
2022-05-18 13:17 Christian Grothoff New Issue
2022-05-18 13:17 Christian Grothoff Status new => assigned
2022-05-18 13:17 Christian Grothoff Assigned To => MS
2022-05-19 08:05 ms-mantis Note Added: 0018906
2022-05-26 12:07 ms-mantis Note Added: 0018907
2022-05-26 12:14 ms-mantis Note Added: 0018908
2022-05-27 15:25 ms-mantis Note Added: 0018909
2022-06-24 13:54 Christian Grothoff Status assigned => resolved
2022-06-24 13:54 Christian Grothoff Resolution open => fixed
2022-06-24 13:54 Christian Grothoff Fixed in Version => 0.1
2022-06-24 13:54 Christian Grothoff Note Added: 0018934