View Issue Details

IDProjectCategoryView StatusLast Update
0007213GNUnetmessenger servicepublic2022-06-04 23:13
Reporterthejackimonster Assigned Tothejackimonster  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionGit master 
Target Version0.17.0Fixed in Version0.16.4 
Summary0007213: Updating handle of messenger service does not do anything
DescriptionUpdating the messenger service handle is a function to allow optional forward secrecy and utilizing automatic chaining of the old and the new key for signing messages. Currently it seems like the function isn't doing anything besides reloading the same ego from identity service. This behavior is not intended. So I would flag this as not working.
Steps To Reproduce1. Use any ego with the messenger service.
2. Call GNUNET_MESSENGER_update().
3. Notice that the identity callback gets called as intended but the key and therefore the identity has not changed.
Additional InformationThis should get fixed inside of update_handle() in gnunet-service-messenger_handle.c!

The ego store should have all necessary functionality to delete the old ego, create a new one with the same identifier and update the connected client handle information.
TagsNo tags attached.

Activities

thejackimonster

2022-04-02 20:10

developer   ~0018850

The functionality of GNUNET_MESSENGER_update() is now implemented and seems to work. However renaming does not always work properly because the entries in the ego store will not be updated in all cases.

So I will probably try to fix that before closing this issue.

thejackimonster

2022-04-05 22:50

developer   ~0018853

Renaming should now be fixed as well because the service will now avoid optimizing an ego lookup and instead check the identity service for accurate information.

Just for transparency: The previous fix was done with commit "e95235a5f71aa40dea29a02cd8d4d1625add7d39" and the later fix with commit "d887cda509e0001adcdeb74feca80a71416827b7".

thejackimonster

2022-04-05 22:52

developer   ~0018854

Updating the key used by the messenger service is now implemented and renaming seems to work consistently.

Issue History

Date Modified Username Field Change
2022-03-31 22:44 thejackimonster New Issue
2022-03-31 22:44 thejackimonster Status new => assigned
2022-03-31 22:44 thejackimonster Assigned To => thejackimonster
2022-04-02 20:10 thejackimonster Note Added: 0018850
2022-04-05 22:50 thejackimonster Note Added: 0018853
2022-04-05 22:52 thejackimonster Status assigned => resolved
2022-04-05 22:52 thejackimonster Resolution open => fixed
2022-04-05 22:52 thejackimonster Fixed in Version => 0.16.4
2022-04-05 22:52 thejackimonster Note Added: 0018854
2022-04-30 21:10 schanzen Target Version 0.17.0 => 0.16.4
2022-06-04 23:13 schanzen Target Version 0.16.4 => 0.17.0