View Issue Details

IDProjectCategoryView StatusLast Update
0007183Talerexchange API (HTTP specification)public2022-11-04 20:52
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.9 
Target Version0.9Fixed in Version0.9 
Summary0007183: GET on /reserves/$RID should not return the history
DescriptionComputing the reserve history is a major cost driver, and completely unnecessary if the wallet and exchange agree anyway and the wallet merely wants to know if the credit has arrived. As per the P2P API, we had plans to have a POST to request the full history (and pay for it!). Alternatively, we may return the full history on a failed withdraw (insufficient balance). There seems to be no good reason to always return the full history.

So the GET /reserves/ API should be changed to ONLY return the latest reserve balance.
TagsNo tags attached.

Activities

Christian Grothoff

2022-03-20 14:49

manager   ~0018821

C client API was changed to no longer return the history. Spec also. Exchange implementation still returns the history, but mostly so that we can still benchmark the history generation logic for the time being.

Christian Grothoff

2022-06-05 14:30

manager   ~0018918

It no longer does.

Issue History

Date Modified Username Field Change
2022-03-03 19:42 Christian Grothoff New Issue
2022-03-03 19:42 Christian Grothoff Status new => assigned
2022-03-03 19:42 Christian Grothoff Assigned To => Christian Grothoff
2022-03-20 14:49 Christian Grothoff Note Added: 0018821
2022-06-05 14:30 Christian Grothoff Status assigned => resolved
2022-06-05 14:30 Christian Grothoff Resolution open => fixed
2022-06-05 14:30 Christian Grothoff Fixed in Version => 0.9
2022-06-05 14:30 Christian Grothoff Note Added: 0018918
2022-10-20 10:46 Christian Grothoff Product Version 0.8.5 => 0.9
2022-11-04 20:52 Christian Grothoff Status resolved => closed