View Issue Details

IDProjectCategoryView StatusLast Update
0007052Talermerchant backend API (C)public2021-11-20 21:27
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0007052: obtain KYC status on deposit
DescriptionRight now, the merchant does not obtain the KYC status when a deposit happens, leaving it uninitialized.
Only when the backoffice staff manually requests the status of a deposit the backend would fetch the KYC status, and notice that we might not get paid because of it.
We might instead want to cache (in RAM) if we know the exchange_kyc_serial for a particular bank account at an exchange yet, and if we do NOT know it, directly trigger the GET /deposits/.../ request at the exchange as part of the POST /pay handler. That way, we do not _always_ have to bother fetching the KYC status (inside the exchange) or fetching/updating it at the merchant, but we would also notice immediately if a KYC is missing, and not only once a staff member goes hunting for missing wire transfers.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-10-20 20:11 Christian Grothoff New Issue
2021-10-20 20:11 Christian Grothoff Status new => assigned
2021-10-20 20:11 Christian Grothoff Assigned To => Christian Grothoff
2021-11-20 21:27 Christian Grothoff Status assigned => resolved
2021-11-20 21:27 Christian Grothoff Resolution open => fixed
2021-11-20 21:27 Christian Grothoff Fixed in Version => 0.9
2021-11-20 21:27 Christian Grothoff Target Version => 0.9