View Issue Details

IDProjectCategoryView StatusLast Update
0006934Talerexchangepublic2021-07-23 14:24
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0006934: add expected currency to JSON spec parser
DescriptionSince it's easy to forget checking the currency (and merchant/exchange are single-currency), it would be a good idea to include the "desired currency" in the TALER_JSON_spec_amount.
TagsNo tags attached.

Relationships

duplicate of 0006939 resolvedChristian Grothoff TALER_JSON_spec_amount should have build-in currency compatibility check 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-07-22 17:14 Florian Dold New Issue
2021-07-22 17:14 Florian Dold Status new => assigned
2021-07-22 17:14 Florian Dold Assigned To => Christian Grothoff
2021-07-23 14:24 Christian Grothoff Relationship added duplicate of 0006939
2021-07-23 14:24 Christian Grothoff Status assigned => resolved
2021-07-23 14:24 Christian Grothoff Resolution open => duplicate
2021-07-23 14:24 Christian Grothoff Fixed in Version => 0.9
2021-07-23 14:24 Christian Grothoff Product Version => git (master)
2021-07-23 14:24 Christian Grothoff Target Version => 0.9