View Issue Details

IDProjectCategoryView StatusLast Update
0006930AnastasisC client librarypublic2022-06-28 11:07
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionno change required 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionGit master 
Target Version0.3.0Fixed in Version0.3.0 
Summary0006930: check truth expiration is included properly in policy expiration
DescriptionThe current API does not return when truth expires after uploads, which is probably fine as truth uploads are fully client-controlled.
However, we should double check that the truth expiration is correctly set and always at the same time where the accounts with the encrypted recovery document expire --- as we only show the policy expiration in the UI, and it would be bad if the policy persisted longer than the truth. Needs testing/review.
TagsNo tags attached.

Activities

Christian Grothoff

2022-06-28 11:06

manager   ~0018943

Double-checked code and database. reducer logic ensures that the expiration (in years) is the same for truth and recdoc. Minor (second-level) differences may arise due to time progressing between the HTTP requests, but that is acceptable.

Issue History

Date Modified Username Field Change
2021-07-19 14:29 Christian Grothoff New Issue
2021-07-19 14:29 Christian Grothoff Priority normal => low
2021-07-19 14:29 Christian Grothoff Status new => acknowledged
2021-12-31 12:42 Christian Grothoff Assigned To => Christian Grothoff
2021-12-31 12:42 Christian Grothoff Status acknowledged => assigned
2022-04-13 19:20 Christian Grothoff Target Version 0.3.0 => 0.4.0
2022-06-28 11:06 Christian Grothoff Status assigned => resolved
2022-06-28 11:06 Christian Grothoff Resolution open => fixed
2022-06-28 11:06 Christian Grothoff Fixed in Version => 0.3.0
2022-06-28 11:06 Christian Grothoff Note Added: 0018943
2022-06-28 11:07 Christian Grothoff Resolution fixed => no change required
2022-06-28 11:07 Christian Grothoff Target Version 0.4.0 => 0.3.0