View Issue Details

IDProjectCategoryView StatusLast Update
0006835Talermechant backendpublic2021-04-16 15:33
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PriorityimmediateSeverityblockReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0006835: demo merchant went into an infinite loop running a prepared statement
DescriptionApr 07 23:28:32-421643 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
Apr 07 23:28:32-429704 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
Apr 07 23:28:32-429991 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
Apr 07 23:28:32-438018 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
Apr 07 23:28:32-438304 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
Apr 07 23:28:32-454683 taler-merchant-httpd-4168595 DEBUG Running prepared statement `insert_exchange_signkey' on 0x561ad7558670
TagsNo tags attached.

Activities

Christian Grothoff

2021-04-08 00:02

manager   ~0017709

Note: this may have been caused by not upgrading the database schema. Still, we should never end up in a loop that can only be kill -9'ed.
To be investigated more.

Christian Grothoff

2021-04-08 12:04

manager   ~0017711

1e10f06..4f8cb89 adds a 1 minute delay for re-trying /keys if /keys was expired by the time we did the download. Alas, this does not explain the need to kill with -9. More investigation needed.

Christian Grothoff

2021-04-16 15:33

manager   ~0017748

Tried, but cannot reproduce this in any way with Git master. Resolving.

Issue History

Date Modified Username Field Change
2021-04-07 23:32 Christian Grothoff New Issue
2021-04-07 23:32 Christian Grothoff Status new => assigned
2021-04-07 23:32 Christian Grothoff Assigned To => Christian Grothoff
2021-04-08 00:02 Christian Grothoff Note Added: 0017709
2021-04-08 12:04 Christian Grothoff Note Added: 0017711
2021-04-16 15:33 Christian Grothoff Status assigned => resolved
2021-04-16 15:33 Christian Grothoff Resolution open => unable to reproduce
2021-04-16 15:33 Christian Grothoff Fixed in Version => 0.9
2021-04-16 15:33 Christian Grothoff Note Added: 0017748
2021-04-16 15:33 Christian Grothoff Target Version 0.8 => 0.9