View Issue Details

IDProjectCategoryView StatusLast Update
0006803Talermerchant backoffice SPApublic2021-03-23 13:30
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Versiongit (master) 
Summary0006803: application ask for the token twice when accessing the update page of the default instance
Descriptioncurrently, when login in, the app save the token under local storage with key `backend-token`

after clicking on the update icon in the instances list, it redirect to the settings page of the instance
since every instance may have different token, it use the token in the local storage with key `backend-token-$ID`

by design, `backend-token` and `backend-token-default` will be always the same.

it is safe to check if the instance == default then use backend-token instead of backend-token-$ID ?
Steps To ReproduceLogin into a backend with auth token, should ask for token
then click in default instance, should redirect to /instance/default/update
here, it will ask for token again
TagsNo tags attached.

Activities

Florian Dold

2021-03-10 22:16

manager   ~0017610

Yes, I think we can make it a hardcoded assumption that the named "default" instance always corresponds to the actual default instance.

sebasjm

2021-03-23 13:29

developer   ~0017636

solved, default instance use `backend-token`

Issue History

Date Modified Username Field Change
2021-03-10 21:57 sebasjm New Issue
2021-03-10 21:57 sebasjm Status new => assigned
2021-03-10 21:57 sebasjm Assigned To => sebasjm
2021-03-10 22:16 Florian Dold Note Added: 0017610
2021-03-23 13:29 sebasjm Note Added: 0017636
2021-03-23 13:30 sebasjm Status assigned => resolved
2021-03-23 13:30 sebasjm Resolution open => fixed
2021-03-23 13:30 sebasjm Fixed in Version => git (master)