View Issue Details

IDProjectCategoryView StatusLast Update
0006775Talermechant backendpublic2021-04-16 18:32
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0006775: investigate assertions from merchant-2021-02-26.log
Descriptiondold@prismo ~/tmp> cat merchant-2021-02-26.log | grep "Assertion failed" | sed 's/.*ERROR //' | sort | uniq

Assertion failed at taler-merchant-httpd_get-orders-ID.c:1061.
Assertion failed at taler-merchant-httpd_post-tips-ID-pickup.c:934.
TagsNo tags attached.

Activities

Christian Grothoff

2021-03-04 10:42

manager   ~0017589

Assertion failed at taler-merchant-httpd_get-orders-ID.c:1061. is a bogus assertion, the god h_contract_terms could be legitimately uninitialized. Removed the assertion in 950f7cd..c2a9a82

Christian Grothoff

2021-03-04 10:46

manager   ~0017590

2nd assertion: the logic seems fine, could be a disagreement over fees / tip balance between exchange and wallet logic.
We should probably do the tipping demo ourselves a few times with the wallet to see if we can reproduce (and what amounts are involved).

Christian Grothoff

2021-04-16 18:32

manager   ~0017750

Resolving, as 2nd part was unable to reproduce.

Issue History

Date Modified Username Field Change
2021-03-01 13:20 Florian Dold New Issue
2021-03-01 13:20 Florian Dold Status new => assigned
2021-03-01 13:20 Florian Dold Assigned To => Christian Grothoff
2021-03-04 10:42 Christian Grothoff Note Added: 0017589
2021-03-04 10:46 Christian Grothoff Note Added: 0017590
2021-04-16 18:32 Christian Grothoff Status assigned => resolved
2021-04-16 18:32 Christian Grothoff Resolution open => unable to reproduce
2021-04-16 18:32 Christian Grothoff Fixed in Version => 0.9
2021-04-16 18:32 Christian Grothoff Note Added: 0017750
2021-04-16 18:32 Christian Grothoff Product Version => git (master)
2021-04-16 18:32 Christian Grothoff Target Version => 0.9