View Issue Details

IDProjectCategoryView StatusLast Update
0006732Talerdocumentationpublic2021-03-01 13:01
ReporterLUG Assigned ToFlorian Dold  
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Summary0006732: API type links are broken
Description* on e.g. https://docs.taler.net/core/api-merchant.html#instance-management
* click on e.g. "Location" (defined further down on the same page) or "Amount" (defined nowhere?)
* and this will link to a 404 at https://docs.taler.net/core/core/api-merchant.html#tsref-type-Location
TagsNo tags attached.

Activities

ttn

2021-02-01 11:44

developer   ~0017480

Sphinx problem?

Florian Dold

2021-02-01 11:58

manager   ~0017481

Will look into this when I find time. It looks like the hyperlinks don't work correctly across different documents when they're in nested directories.

ttn

2021-02-01 12:08

developer   ~0017482

I see that even in the same document (e.g., "Merchant") the expanded target has "core/core/" in it.

Florian Dold

2021-03-01 13:01

manager   ~0017578

Fixed in f4f1fa0

Issue History

Date Modified Username Field Change
2021-01-30 21:42 LUG New Issue
2021-01-30 21:42 LUG Status new => assigned
2021-01-30 21:42 LUG Assigned To => Stefan
2021-01-30 21:43 LUG Assigned To Stefan => ttn
2021-01-30 21:50 LUG Description Updated View Revisions
2021-01-30 21:57 LUG Description Updated View Revisions
2021-01-30 23:55 Christian Grothoff Severity minor => text
2021-02-01 11:44 ttn Note Added: 0017480
2021-02-01 11:44 ttn Assigned To ttn => Florian Dold
2021-02-01 11:58 Florian Dold Status assigned => acknowledged
2021-02-01 11:58 Florian Dold Note Added: 0017481
2021-02-01 12:08 ttn Note Added: 0017482
2021-03-01 13:01 Florian Dold Status acknowledged => resolved
2021-03-01 13:01 Florian Dold Resolution open => fixed
2021-03-01 13:01 Florian Dold Note Added: 0017578