View Issue Details

IDProjectCategoryView StatusLast Update
0006718libeufinnexuspublic2021-05-20 16:56
ReporterFlorian Dold Assigned ToMS  
PriorityurgentSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0006718: make sure all "obvious" CRUD operation exist and have tests
DescriptionWe need to make sure that all resources have all reasonable "CRUD" (CReate, Update, Delete) supported, and that these operations are tested.

(And also what happens with dependencies. I.e., we might require that a bank account can't be deleted when there's a facade using it.)
TagsNo tags attached.

Activities

MS

2021-01-30 14:09

manager   ~0017461

This got addressed to some extent, but can't claim now that ALL the operations are thoroughly covered.

MS

2021-02-26 09:38

manager   ~0017565

Last edited: 2021-02-26 11:09

View 2 revisions

The following list should help define which resources are now held in LibEuFin.

Nexus:
- user account
- bank connection
- facade
- bank account
- Ebics subscriber
- scheduled tasks
- permission settings
- initiated payments

Sandbox:
- bank account
- Ebics subscriber
- Ebics host

MS

2021-03-22 19:02

manager   ~0017631

After internal discussion, this bug will be solved just after every API endpoint will be covered by a test.

MS

2021-05-07 11:47

manager   ~0017795

Testing creation and deletion/modification of a permission: b414de853371b98d125a92a4d9e9578be9b0f0d5

Deletion is modification because is achieved by setting the "revoke" status to one existing permission.

MS

2021-05-10 11:59

manager   ~0017806

Creation and update of Nexus users gets tested here: 9772e5837ea861b23690b6727f1a67c7b2edf1da.

The update happens in terms of password change.

MS

2021-05-10 12:04

manager   ~0017807

Payment initiations do not need a dedicate test case because their operations (*) are quite basic, and tested already
along the whole test suite.

(*) The update operation is basically the submission of a initiated payment. There is no deletion operation so far.

MS

2021-05-12 10:04

manager   ~0017838

The bank account resource (as offered by Nexus) is tested here: 41b65e90b9eb1a0a4a999bce75df29a0ea3aedcc.

MS

2021-05-12 11:59

manager   ~0017839

The bank connection resource gets tested here: 83b02069c931306c72c470e0285693719f65d0ca

This test however goes only through the creation and deletion of one, as updates got already tested
along the whole test suite. Updates include fetching transactions and bank account information from banks.

MS

2021-05-14 12:40

manager   ~0017848

Last edited: 2021-05-14 12:55

View 2 revisions

Tasks scheduling gets tested here: dcef82d677f8b79b0a7b78f485f08fcd0f7d8c96

MS

2021-05-18 18:08

manager   ~0017876

Facade creation and deletion get tested here: 0299e719ce4c97748090fa238cb5f68303fb4abf.

MS

2021-05-20 16:56

manager   ~0017884

Nexus resources got covered. Eventually, a separate bug for the Sandbox can be opened.

Issue History

Date Modified Username Field Change
2021-01-23 20:39 Florian Dold New Issue
2021-01-23 22:26 Florian Dold Assigned To => MS
2021-01-23 22:26 Florian Dold Status new => assigned
2021-01-30 14:09 MS Note Added: 0017461
2021-02-26 09:38 MS Note Added: 0017565
2021-02-26 11:09 MS Note Edited: 0017565 View Revisions
2021-03-22 19:02 MS Note Added: 0017631
2021-05-07 11:47 MS Note Added: 0017795
2021-05-10 11:59 MS Note Added: 0017806
2021-05-10 12:04 MS Note Added: 0017807
2021-05-12 10:04 MS Note Added: 0017838
2021-05-12 11:59 MS Note Added: 0017839
2021-05-14 12:40 MS Note Added: 0017848
2021-05-14 12:55 MS Note Edited: 0017848 View Revisions
2021-05-18 18:08 MS Note Added: 0017876
2021-05-20 16:56 MS Status assigned => resolved
2021-05-20 16:56 MS Resolution open => fixed
2021-05-20 16:56 MS Note Added: 0017884