View Issue Details

IDProjectCategoryView StatusLast Update
0006672Talerdeployment and operationspublic2021-01-02 15:36
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0006672: create Debian package for taler-mdb and taler-merchant
DescriptionShould be easy, given the exchange package logic.
TagsNo tags attached.

Activities

Christian Grothoff

2021-01-01 22:45

manager   ~0017294

The packages (merchant and exchange!) currently fail because:
$ /usr/bin/taler-exchange-dbinit
Jan 01 22:44:31-996272 util-plugin-52510 ERROR `lt_dlopenext' failed for library `libtaler_plugin_exchangedb_postgres' with error: file not found
Failed to initialize database plugin.

Not sure why we fail to look in the right path.

Christian Grothoff

2021-01-02 11:27

manager   ~0017295

/proc/PID/maps parser never worked for 64-bit architectures, fixed now.

Christian Grothoff

2021-01-02 15:36

manager   ~0017296

Debian packages work, alas 0006673 is still an issue. But that goes beyond packaging.

Issue History

Date Modified Username Field Change
2020-12-31 23:15 Christian Grothoff New Issue
2020-12-31 23:15 Christian Grothoff Status new => assigned
2020-12-31 23:15 Christian Grothoff Assigned To => Christian Grothoff
2021-01-01 22:45 Christian Grothoff Note Added: 0017294
2021-01-02 11:27 Christian Grothoff Note Added: 0017295
2021-01-02 15:36 Christian Grothoff Status assigned => resolved
2021-01-02 15:36 Christian Grothoff Resolution open => fixed
2021-01-02 15:36 Christian Grothoff Fixed in Version => 0.9
2021-01-02 15:36 Christian Grothoff Note Added: 0017296