View Issue Details

IDProjectCategoryView StatusLast Update
0006600Talermechant backendpublic2020-10-07 12:47
ReporterMS Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006600: Refund should not be offered when the frontend did not give a delay.
DescriptionIf the merchant frontend does not give a "refund_delay" value upon creating a order, then no refund option should be offered for the item.
TagsNo tags attached.

Activities

Christian Grothoff

2020-09-10 20:02

manager   ~0016962

Last edited: 2020-09-10 20:02

View 2 revisions

Eh, offered by whom? Oh, and to clarify: it's OK if the /refund API is used in this case, it's just not _guaranteed_ that any refund will be possible because the exchange may then wire the funds virtually immediately to the merchant. So I'm not sure what change you expect is needed to the merchant here. Maybe the spec is still unclear? ;-)

Florian Dold

2020-09-11 13:16

manager   ~0016963

After clarifying this with Marcello: The merchant backend currently allows requests to /{orders}/refund even if giving a refund for this order doesn't make much sense, because the refund deadline is set to "0".

Basically Marcello suggests to add a "sanity check" in the merchant that gives some error when the storefront tries POST /{orders}/refund for an order where we already know giving a refund doesn't make much sense.

(Sure, it's possible that the exchange didn't wire the money yet ... but such a check by the backend might make sense to prevent the common error of forgetting to set the refund deadline. The current behavior just hides it between non-deterministic behavior.)

Christian Grothoff

2020-10-07 12:45

manager   ~0017000

Documented new 403 status code in 0212cfe..d356cbb

Christian Grothoff

2020-10-07 12:47

manager   ~0017001

Implemented in e2406406..7d81706c

Issue History

Date Modified Username Field Change
2020-09-10 19:52 MS New Issue
2020-09-10 19:52 MS Status new => assigned
2020-09-10 19:52 MS Assigned To => MS
2020-09-10 20:02 Christian Grothoff Note Added: 0016962
2020-09-10 20:02 Christian Grothoff Note Edited: 0016962 View Revisions
2020-09-11 13:16 Florian Dold Note Added: 0016963
2020-09-11 22:54 Christian Grothoff Assigned To MS => Christian Grothoff
2020-10-07 12:45 Christian Grothoff Note Added: 0017000
2020-10-07 12:47 Christian Grothoff Note Added: 0017001
2020-10-07 12:47 Christian Grothoff Status assigned => resolved
2020-10-07 12:47 Christian Grothoff Resolution open => fixed
2020-10-07 12:47 Christian Grothoff Fixed in Version => 0.8
2020-10-07 12:47 Christian Grothoff Product Version => git (master)
2020-10-07 12:47 Christian Grothoff Target Version => 0.8