View Issue Details

IDProjectCategoryView StatusLast Update
0006250Talerlibeufin-nexuspublic2023-12-22 14:00
ReporterFlorian Dold Assigned To 
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionsuspended 
Target Version0.9.4Fixed in Version0.9.4 
Summary0006250: implement advanced permission storage and checking
DescriptionRight now, the nexus doesn't do any permissions at all beyond authenticating the user.
TagsNo tags attached.

Activities

MS

2023-04-11 11:03

reporter   ~0020065

It does. This is one example from the Taler facade:
https://git.taler.net/libeufin.git/tree/nexus/src/main/kotlin/tech/libeufin/nexus/Taler.kt?id=1b9fbb02ac2d2eb402c18877079d1bdbae03a620#n180

MS

2023-04-11 11:08

reporter   ~0020066

Although a valid issue, that can be moved to another release because Nexus
will rarely be exposed online AND have more than one user at the first deployment
with Postfinance. On top of that, the note above shows that checks do take place.

It remains to check WHERE ELSE they may be needed and test them.

Christian Grothoff

2023-12-02 11:48

manager   ~0020700

I'm confused. In the current architecture, is this about *sandbox* (not nexus), or simply resolved/dead?

MS

2023-12-03 20:23

reporter   ~0020718

Last edited: 2023-12-03 20:28

It can still affect Nexus, because once it'll serve the TWG you might still want permission-based access control. If you want permission-based access control for the bank, I'd suggest to file another bug.

MS

2023-12-19 09:33

reporter   ~0020774

Not planning to serve permission-based accessed control at the moment

Issue History

Date Modified Username Field Change
2020-05-21 09:05 Florian Dold New Issue
2020-11-10 12:17 MS Target Version => 0.9.3
2023-04-11 11:03 MS Note Added: 0020065
2023-04-11 11:08 MS Note Added: 0020066
2023-04-11 11:08 MS Target Version 0.9.3 =>
2023-04-13 20:38 Florian Dold Category nexus => libeufin-nexus
2023-04-13 20:50 Florian Dold Project libeufin => Taler
2023-04-17 11:42 Florian Dold Target Version => post-1.0
2023-04-17 11:42 Florian Dold Summary implement permission storage and checking => implement advanced permission storage and checking
2023-12-02 11:48 Christian Grothoff Note Added: 0020700
2023-12-03 20:23 MS Note Added: 0020718
2023-12-03 20:28 MS Note Edited: 0020718
2023-12-19 09:32 MS Status new => resolved
2023-12-19 09:33 MS Resolution open => suspended
2023-12-19 09:33 MS Note Added: 0020774
2023-12-22 14:00 Christian Grothoff Fixed in Version => 0.9.4
2023-12-22 14:00 Christian Grothoff Target Version post-1.0 => 0.9.4