View Issue Details

IDProjectCategoryView StatusLast Update
0006018Talerotherpublic2020-03-31 16:04
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0006018: The python taler-util Amount class is unnecessarily hard to use
DescriptionThere is no reason for the Amount class to be mutable. It is difficult to even create a copy of an Amount.
TagsNo tags attached.

Activities

Florian Dold

2020-01-07 17:41

manager   ~0015238

Oh and we also need something to handle negative amounts, since currently "zero crossing" must be implemented manually, which is very error-prone.

Florian Dold

2020-01-15 16:43

manager   ~0015279

We now have an immutable amount class, as well as an immutable SignedAmount class.

Issue History

Date Modified Username Field Change
2019-12-28 16:14 Florian Dold New Issue
2020-01-07 17:41 Florian Dold Note Added: 0015238
2020-01-07 19:17 Florian Dold Assigned To => Florian Dold
2020-01-07 19:17 Florian Dold Status new => assigned
2020-01-15 16:43 Florian Dold Status assigned => resolved
2020-01-15 16:43 Florian Dold Resolution open => fixed
2020-01-15 16:43 Florian Dold Note Added: 0015279
2020-03-31 16:04 Christian Grothoff Status resolved => closed