View Issue Details

IDProjectCategoryView StatusLast Update
0005863Talermerchant backend API (C)public2019-08-31 14:10
ReporterFlorian DoldAssigned ToFlorian Dold 
PriorityhighSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version 
Summary0005863: trying to pay again for a refunded contract crashes the merchant
DescriptionIt looks like the wallet is doing something wrong with payment re-playing in this case, but that should not crash the merchant!

#0 0x00007f34151907bb in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f341517b535 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007f34153e4a29 in GNUNET_abort_ () at common_logging.c:292
#3 0x0000560af9ff4e24 in check_payment_sufficient (pc=0x560afaf10480) at taler-merchant-httpd_pay.c:728
#4 0x0000560af9ff938b in begin_transaction (pc=0x560afaf10480) at taler-merchant-httpd_pay.c:1997
#5 0x0000560af9ff9749 in handler_pay_json (connection=0x560afaf143f0, root=0x560afad7d1c0, pc=0x560afaf10480)
    at taler-merchant-httpd_pay.c:2113
TagsNo tags attached.

Activities

Florian Dold

2019-08-31 13:51

manager   ~0014827

The problem is actually that the refund gets computed incorrectly and ends up being higher than even the total contract amount.

Florian Dold

2019-08-31 14:10

manager   ~0014828

Fixed in
4b47e468889379e97da465bbc13f9a7314d8c6f2
8d841f8c99751590333c7f34ce96f51dcd9e27b6

Issue History

Date Modified Username Field Change
2019-08-30 17:55 Florian Dold New Issue
2019-08-30 17:55 Florian Dold Status new => assigned
2019-08-30 17:55 Florian Dold Assigned To => Christian Grothoff
2019-08-31 11:10 Florian Dold Priority normal => high
2019-08-31 11:10 Florian Dold Severity minor => crash
2019-08-31 11:10 Florian Dold Product Version => SVN HEAD
2019-08-31 11:10 Florian Dold Target Version => 0.6
2019-08-31 13:51 Florian Dold Note Added: 0014827
2019-08-31 14:10 Florian Dold Assigned To Christian Grothoff => Florian Dold
2019-08-31 14:10 Florian Dold Status assigned => resolved
2019-08-31 14:10 Florian Dold Resolution open => fixed
2019-08-31 14:10 Florian Dold Note Added: 0014828