View Issue Details

IDProjectCategoryView StatusLast Update
0005860Talerwallet (WebExtensions)public2021-10-05 14:34
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0005860: browser wallet should allow completing an operation with a mobile/cli wallet
DescriptionThere should be some button/link, and it should cause the wallet to render a QR code and link in lieu of the merchant/bank/audtior doing that.
TagsNo tags attached.

Activities

Florian Dold

2019-11-02 21:27

manager   ~0015050

For this, the taler://pay QR code needs to be able to also transmit the nonce to the mobile wallet, as the browser wallet will have already claimed it.

sebasjm

2021-09-17 20:51

developer   ~0018396

the wallet that create the qr/link now use a parameter to share the nonce-private
the wallet that use this link will detect this parameter and use that private nonce instead of creating a new one

couldn't test with android wallet but should works since I have tested with wallet cli

sebasjm

2021-10-05 14:34

developer   ~0018427

Tested and works

Issue History

Date Modified Username Field Change
2019-08-29 10:07 Florian Dold New Issue
2019-08-29 10:07 Florian Dold Status new => assigned
2019-08-29 10:07 Florian Dold Assigned To => Florian Dold
2019-11-02 21:27 Florian Dold Note Added: 0015050
2021-08-24 20:45 Christian Grothoff Assigned To Florian Dold => sebasjm
2021-08-30 16:56 sebasjm Status assigned => confirmed
2021-09-17 20:51 sebasjm Note Added: 0018396
2021-09-20 04:02 sebasjm Assigned To sebasjm => Florian Dold
2021-09-20 04:02 sebasjm Status confirmed => feedback
2021-10-05 14:34 sebasjm Status feedback => resolved
2021-10-05 14:34 sebasjm Resolution open => fixed
2021-10-05 14:34 sebasjm Note Added: 0018427