View Issue Details

IDProjectCategoryView StatusLast Update
0005683libmicrohttpdbuild systempublic2019-10-14 23:03
Reporterng0Assigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Platformamd64OSNetBSDOS Version8.99.36
Product Version0.9.63 
Target Version0.9.67Fixed in Version0.9.67 
Summary0005683: perf_get_concurrent fails
Description===========================================================
   GNU Libmicrohttpd 0.9.63: src/testcurl/test-suite.log
===========================================================

# TOTAL: 37
# PASS: 36
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: perf_get_concurrent
=========================

Parallel GETs using internal thread with select(): 10471.204188 requests/s
Parallel GETs using internal thread with select() and thread per connection: 9090.909091 requests/s
Parallel GETs using internal thread pool with select(): 9569.377990 requests/s
Parallel GETs using external select: 9661.835749 requests/s
Parallel GETs using internal thread with 'auto': 9803.921569 requests/s
Parallel GETs using internal thread with 'auto' and thread per connection: 9009.009009 requests/s
Parallel GETs using internal thread pool with 'auto': 9302.325581 requests/s
Parallel GETs using internal thread with poll(): 10526.315789 requests/s
curl_easy_perform failed: `Couldn't connect to server'
Error performing internal thread with poll() and thread per connection test: curl error
Parallel GETs using internal thread pool with poll(): 9523.809524 requests/s
Error (code: 4)
FAIL perf_get_concurrent (exit status: 1)

TagsNo tags attached.

Activities

ng0

2019-04-07 14:06

reporter   ~0014273

More info: This affected the `make test` on my system pkgsrc-wip checkout (failed the test on 1st and 2nd run), but it did not affect the run of the test on an older NetBSD of someone else (in other words, succeeded there, same architecture).

ng0

2019-04-07 14:13

reporter   ~0014274

Correction: success on 2nd run here too. So it can't be reproduced easily.

Karlson2k

2019-05-27 14:55

developer   ~0014445

Could you re-try with updated master?
You can try several runs to ensure that no test fail.

ng0

2019-05-27 21:34

reporter   ~0014452

Okay, will do so later this week.

ng0

2019-05-27 21:35

reporter   ~0014453

I can't assign bugs to myself here, if with my access level here it is possible for you, please assign it to me. otherwise tell me and I'll just make a note on paper to remind myself.

Karlson2k

2019-05-28 09:47

developer   ~0014454

This bug should be already fixed.
No need to assign, just need confirmation that problem is fixed for you as well.

Karlson2k

2019-06-03 10:20

developer   ~0014500

ng0, any report is appreciated.
My tests on NetBSD 7.2 and 8.0 were fine, except fact that TCP_PUSH do not work well on this platform so some *11 tests are taking too long to complete (5 requests per second is too slow).

ng0

2019-07-14 00:01

reporter   ~0014669

NetBSD 8.99.48 GENERIC amd64: passes, but hangs as observed before.
No idea which 8.99.* someone was on who reported to me that the testsuite does not work (or what it was), or which architecture.
But if any regression appears in pkgsrc platforms I will be able to handle this after gsoc. The new release is now in pkgsrc upstream and I'm the package maintainer.

PASS: test_https_get_select
SKIP: test_tls_options
PASS: test_tls_authentication
PASS: test_https_get_parallel
SKIP: test_https_get_parallel_threads
PASS: test_https_sni
SKIP: test_https_session_info
PASS: test_https_time_out
PASS: test_https_multi_daemon
PASS: test_https_get
PASS: test_empty_response
============================================================================
Testsuite summary for GNU Libmicrohttpd 0.9.65
============================================================================
# TOTAL: 11
# PASS: 8
# SKIP: 3
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 0
============================================================================
Making check in .
Making check in examples
Making check in .
Making check in .
Making check in po
Making check in doc
Making check in .
Making check in doxygen
Making check in examples
Making check in .

ng0

2019-10-14 13:40

reporter   ~0015012

With recent default branch I can not reproduce this, okay to close.

ng0

2019-10-14 13:41

reporter   ~0015013

If it resurfaces on packaging the next release, I'll open a new bug.

Issue History

Date Modified Username Field Change
2019-04-07 13:48 ng0 New Issue
2019-04-07 14:06 ng0 Note Added: 0014273
2019-04-07 14:13 ng0 Note Added: 0014274
2019-05-27 14:55 Karlson2k Note Added: 0014445
2019-05-27 21:34 ng0 Note Added: 0014452
2019-05-27 21:35 ng0 Note Added: 0014453
2019-05-28 09:47 Karlson2k Note Added: 0014454
2019-06-03 10:20 Karlson2k Note Added: 0014500
2019-07-14 00:01 ng0 Note Added: 0014669
2019-10-14 13:40 ng0 Note Added: 0015012
2019-10-14 13:41 ng0 Note Added: 0015013
2019-10-14 23:03 Christian Grothoff Assigned To => Christian Grothoff
2019-10-14 23:03 Christian Grothoff Status new => resolved
2019-10-14 23:03 Christian Grothoff Resolution open => unable to reproduce
2019-10-14 23:03 Christian Grothoff Fixed in Version => 0.9.67
2019-10-14 23:03 Christian Grothoff Target Version => 0.9.67