View Issue Details

IDProjectCategoryView StatusLast Update
0005528GNUnetTCP transportpublic2020-07-28 08:49
ReporterChristian GrothoffAssigned Tot3sserakt 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionGit master 
Target Version0.13.1Fixed in Version0.13.1 
Summary0005528: TCP *communicator* bindto option should support DNS names
DescriptionRight now, only numeric IPv4/IPv6 addresses are allowed.
Note that this might be a tad tricky, as DNS names can yield multiple IPs. But we should at least support just resolving a name to the first DNS response.
TagsNo tags attached.

Relationships

child of 0005710 confirmed TNG meta issue 

Activities

t3sserakt

2020-05-07 08:19

developer   ~0015867

The change to resolve DNS names is done, but there is some strange behavior.

To test the resolving I added entries to /etc/hosts. First it looks like there are problems, when we resolve to a ipv6 address. But now it looks like I only have the problem when using localhost as name to be resolved, even when localhost is not in my /etc/hosts and localhost will be resolved from whatever source.

Christian Grothoff

2020-05-07 09:42

manager   ~0015868

We have 'localhost' hard-coded in src/util/, that's expected. We need that as 'localhost' may need to be resolved to resolve the name of the GNUnet service for name resolution ;-).

t3sserakt

2020-06-12 13:01

developer   ~0016263

Fixed with commit 726ac3ef2

Issue History

Date Modified Username Field Change
2019-01-28 19:19 Christian Grothoff New Issue
2019-01-28 19:19 Christian Grothoff Status new => assigned
2019-01-28 19:19 Christian Grothoff Assigned To => Matthias Wachs
2019-01-28 19:20 Christian Grothoff Assigned To Matthias Wachs =>
2019-01-28 19:20 Christian Grothoff Status assigned => confirmed
2019-02-12 09:07 Christian Grothoff Target Version => 0.12.0
2019-05-02 14:41 Christian Grothoff Relationship added child of 0005710
2019-11-16 18:41 Christian Grothoff Target Version 0.12.0 => 0.13.0
2020-04-03 19:35 t3sserakt Assigned To => t3sserakt
2020-04-03 19:35 t3sserakt Status confirmed => assigned
2020-04-22 17:22 schanzen Target Version 0.13.0 => 0.14.0
2020-05-07 08:19 t3sserakt Note Added: 0015867
2020-05-07 09:42 Christian Grothoff Note Added: 0015868
2020-06-01 00:49 Adminknox Issue cloned: 0006295
2020-06-12 13:01 t3sserakt Status assigned => resolved
2020-06-12 13:01 t3sserakt Resolution open => fixed
2020-06-12 13:01 t3sserakt Fixed in Version => Git master
2020-06-12 13:01 t3sserakt Note Added: 0016263
2020-06-21 22:20 schanzen Fixed in Version Git master => 0.13.0
2020-07-09 08:22 schanzen Fixed in Version 0.13.0 => 0.13.1
2020-07-09 08:22 schanzen Target Version 0.14.0 => 0.13.1
2020-07-28 08:49 schanzen Status resolved => closed