View Issue Details

IDProjectCategoryView StatusLast Update
0005492Talermechant backendpublic2020-08-29 00:01
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0005492: database inconsistency results in internal server error (2501/2705?)
DescriptionMarcello suggests some "some discrepancy exists between db tables".

The DB was reset, the backup is in demo-blue "talerdemo_db_dump.sql". To be investigated.
TagsNo tags attached.

Activities

Christian Grothoff

2019-01-10 14:12

manager   ~0013451

Changing category, as the generated errors point to the merchant backend, not the exchange.

Christian Grothoff

2019-01-10 15:25

manager   ~0013452

529cf92..828cd52 cleans up the /proposal logic improving error messages and proposal generation (nicer style), but also fixing a previously improperly done (lack of transaction scope) pre-flight test for an already existing order. Now the constraint check is simply done by relying on the DB constraint, and then we just run the 'get_order' to confirm that the hard error was indeed the constraint violation and not something else. So in the common case the result should be much faster, and we properly use the transactions now.

It is _not_ clear that this was the bug, though.

Christian Grothoff

2019-01-10 15:34

manager   ~0013453

84d4c87..9b683b2 improves logging in case this bug reappears.

Christian Grothoff

2019-01-10 15:35

manager   ~0013454

Unassigning, as I am not sure how to reproduce (loaded the DB, but would need a matching frontend setup to generate failing transactions). Hopefully the new logging will help diagnose this if this is still an issue.

Christian Grothoff

2020-08-29 00:01

manager   ~0016794

Merchant backend and database schema have changed completely. No point in even trying to reproduce this issue at this point.

Issue History

Date Modified Username Field Change
2018-11-29 13:44 Christian Grothoff New Issue
2018-11-29 13:44 Christian Grothoff Status new => assigned
2018-11-29 13:44 Christian Grothoff Assigned To => Christian Grothoff
2019-01-08 19:12 Christian Grothoff Priority normal => urgent
2019-01-10 14:12 Christian Grothoff Category exchange => mechant backend
2019-01-10 14:12 Christian Grothoff Note Added: 0013451
2019-01-10 15:25 Christian Grothoff Note Added: 0013452
2019-01-10 15:34 Christian Grothoff Note Added: 0013453
2019-01-10 15:35 Christian Grothoff Assigned To Christian Grothoff =>
2019-01-10 15:35 Christian Grothoff Priority urgent => normal
2019-01-10 15:35 Christian Grothoff Note Added: 0013454
2019-01-10 15:36 Christian Grothoff Status assigned => feedback
2020-08-29 00:01 Christian Grothoff Assigned To => Christian Grothoff
2020-08-29 00:01 Christian Grothoff Status feedback => resolved
2020-08-29 00:01 Christian Grothoff Resolution open => unable to reproduce
2020-08-29 00:01 Christian Grothoff Fixed in Version => 0.8
2020-08-29 00:01 Christian Grothoff Note Added: 0016794
2020-08-29 00:01 Christian Grothoff Target Version => 0.8